Start a new topic

IPA building issue

Tried using both the methods as well as using forums method

https://www.wikitude.com/external/doc/documentation/latest/phonegap/ios-framework-scripts-architect.html#ios-app-store-submissions


Now I am getting 

XXXXX/WikitudeSDK.framework/WikitudeSDK' does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. file XXXX/WikitudeSDK.framework/WikitudeSDK' for architecture arm64

 

Now app is not even running after adding the script and nor archiving.


Hi,


Our SDK's iOS framework ships with bitcode support by default.


In that documentation page we describe the purpose of the "wikitude_bitcode.sh" script, which removes bitcode data from the framework to accommodate Xcode projects that do not support bitcode.


Did you run this script on the framework? Your project seems to have bitcode enabled, so you should not run this script. You should take the framework as it is provided in the package, and only run "strip_wikitude_framework.sh" on it before attempting to upload the build to the App Store.


Let us know if the issue persists.



- Damian

Hi,

I tried this as well but still IPA processing is getting failed.

image


Hi,


This looks like a different issue. Is there anything more specific showing up in the logs?



- Damian

image


when I click on the show logs it redirects me to T folder attached in the image.

No other error. I have fixed the previous issue but still IPA is not building.

Hi Team,

Can you please update here asap?

Hi,


Have you already removed all .sh files from the framework before archiving the build?


Also make sure that you are building your project for 64 bit architectures only. We dropped support for 32 bit in our 8.6 release, more details here.

Your project settings should target the "Standard Architectures" option in the latest Xcode release. The values should match the ones in the screenshot I'm attaching.


You should only need those two steps to get an .ipa that can be processed successfully.

If the problem persists, I would suggest removing our framework and any references to it from your project, archiving a new build and attempting to upload that one to the App Store. Just to determine if the issue originates from our framework, or some other dependency you may be using in your project.



- Damian

Hi,

Tried the way you told us. we got same error.

After we removed the wiklitude framework from the app. generated the IPA. screenshot attached below



Hi,


Which Xcode version are you using? Which iOS version are you targeting?


Can you send us the SDK framework file exactly as you have it in the project when archiving the build? Can you send us a sample project where this issue can be reproduced?



- Damian

Hi,

Xcode version: 12.1

Target iOS version: 11.1

Wikitude sok version: 9.8.0


sample link: https://github.com/alexwasner/Wikitude-Swift

You can try here. 



Hi,


That project was last updated 4 years ago, using Swift 3 to work with Wikitude 6.0.

Do you have any updated projects for our 9.8 release that can be built on Xcode 12?


Until then, all I can suggest is to make sure your project matches the settings of the sample app we provide with the release package. That one, after following the steps about running the relevant scripts and removing them from the framework, generates an IPA that can be processed and uploaded to the App Store just fine from Xcode 12.5.



- Damian

capture.png
(27.1 KB)

Hi,


Step by step, this is what I did to upload an IPA to the App Store with the last project you provided:

1. Unzip it, and open Wikitude-Swift-master-2/WikitudeSwiftStarter.xcodeproj

2. Replace your bundle ID and development team so I can build it on my machine (which wouldn't be required on your end)

3. Set the WikitudeSDK.framework in the target general settings to "Embed and Sign" (capture1.png)

4. Exclude armv7 architecture in the target build settings, since your project still targets 32 bit (capture2.png)

5. Open a terminal, cd into the root of your project at Wikitude-Swift-master-2/WikitudeSwiftStarter, then run:

mv WikitudeSDK.framework/*sh .
sh strip_wikitude_framework.sh -s -p WikitudeSDK.framework

The first command moves the scripts outside the framework, the second one strips the simulator architecture build within it. Just as mentioned in our documentation. Your file structure should look like in capture3.png

6. Since the App Store requires some icon sizes, I replaced the Images.xcassets in your project with the one we use in our example project

7. Provide the privacy strings required by the Store in your Info.plist, I took these from our example project as well (capture4.png)

8. Archive it for release targeting "Any iOS Device (arm64)"

9. Open Window/Organizer, select the build and "Distribute App", then follow the regular steps to upload it to the App Store


I encourage you to try the same process. If the issue persists, I would suggest upgrading your Xcode to the latest release before archiving the build again. Maybe try using the Transporter app provided by Apple to upload IPAs to the store.


If even after that you are still having trouble, make sure to review all the steps again very carefully, because this really is everything that is required to upload an app that includes our framework. Otherwise, I'm afraid this issue would be unrelated to our SDK.



- Damian

capture1.png
(151 KB)
capture2.png
(88.6 KB)
capture3.png
(49.5 KB)
capture4.png
(175 KB)
Login or Signup to post a comment