Start a new topic

Flutter 2.0.3 Wikitude 9.6

Wikitude supports flutter2 ???

I tried to install the plugin from the github examples and it gave me error (library "" not found) still including

         ndk {

             abiFilters 'x86', 'x86_64', 'armeabi', 'armeabi-v7a', 'arm64-v8a'


I also tried adding it to a project from scratch but in this case the error is:

Execution failed for task ': augmented_reality_plugin_wikitude: bundleDebugAar'.

> Direct local .aar file dependencies are not supported when building an AAR. The resulting AAR would be broken because the classes and Android resources from any local .aar file dependencies would not be packaged in the resulting AAR. Previous versions of the Android Gradle Plugin produces broken AARs in this case too (despite not throwing this error). The following direct local .aar file dependencies of the: augmented_reality_plugin_wikitude project caused this error: .... / plugin / augmented_reality_plugin_wikitude / android / wikitudesdk / wikitudesdk.aar


flutter doctor:

[✓] Flutter (Channel stable, 2.0.3, on Linux, locale es_ES.UTF-8)

[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)

[✓] Chrome - develop for the web

[✓] Android Studio

[✓] VS Code (version 1.54.3)

[✓] Connected device (2 available)

• No issues found!

4 people have this problem

Dear Aitor,

I have added the code and the project can be build, but I have noticed an issue when I enable the plugin path on pubspec.

On the project I load and save some data on local txt files (like the poi and language preference).

So once the plugin on pubspec is activated I get the following error when I try to load and save the data to the txt file.

The error that I get is the following:

[ERROR:flutter/lib/ui/] Unhandled Exception: MissingPluginException(No implementation found for method getApplicationDocumentsDirectory on channel

E/flutter (21946): #0 MethodChannel._invokeMethod (package:flutter/src/services/platform_channel.dart:156:7)

E/flutter (21946): <asynchronous suspension>

E/flutter (21946): #1 getApplicationDocumentsDirectory (package:path_provider/path_provider.dart:138:24)

E/flutter (21946): <asynchronous suspension>


Could you check if you are still implementing the next piece of code in the build.gradle of your application?

ndk {
    abiFilters 'armeabi-v7a'

If so, please remove it. This was introduced the first time we created the plugin because of a bug within flutter where the was only built for one architecture.



Hi Aitor,

this is not implemented and still have the same issue with getApplicationDocumentsDirectory() every time I try to save something on the local files using path_provider.

The issue you are having at the moment comes from an external plugin that has nothing to do with our own SDK. In addition to that, I have tested the samples in our sample app that are calling the getApplicationDocumentsDirectory() method and everything seems to be working fine.

I would have a question regarding the path_provider plugin version you are using as we are still using 2.0.1 and the latest ones already have changes to support flutter 2.5 which may cause compilatibility issues as our 9.10 SDK version only supports until flutter 2.2.

The issue happens only on the android emulator and not on testing on a connected android device.

The path_provider version that I am using is 2.0.4 that is compatible with dart 2.12.

If you use 2.0.1 I can downgrade, but I don't seen any reason to do this.

I would expect this issue to happen as the emulator runs on a x86 architecture but our SDK is build for ARMv7 and ARMv8 architectures.

Login or Signup to post a comment