Start a new topic

Could not find SDK Java classes, make sure not to obfuscate the "com.wikitude" package.


We are getting this error when starting Android app on Release build:

"[Wikitude SDK] Could not find SDK Java classes, make sure not to obfuscate the "com.wikitude" package."

We are using Xamarin Forms for development and latest Wikitude JS SDK (9.3), and on release build that is used for deployment to Google Play Store, if we turn on assembly linking, app crashes when starting Wikitude AR experience with the above error message.

Android Linker behaviour is set to: "Link SDK Assemblies only"

Even if we set to ignore Wikitude assembly and not to link it, the same error is here. We have tried with several naming to set that Wikitude should not be linked, but it seems it is always linked and thus this exception occurs: "Wikitude.Android" "com.wikitude" "Xamarin.Wikitude.SDK.JS".

Can you please help us with this issue, as the app size is a lot bigger if linker is not turned on, and we need that for store submission.


Did you download the latest NuGet package from this page:

Thx and greetings


Hi Nicola,

yes that is correct, and it is installed as nuget package in solution.

We have an update on this problem. Problem is not with Android Link Mode set to SDKOnly, but with AndroidLinkTool set to "r8" for code shrinking.

That is a default setting on new projects. When we set not to use that tool, app works fine on release build and has smaller size because Linking now does the job.

You can replicate this problem also on your sample Xamarin project. If you set on Android project settings, on release build, to use "r8" code shrinker, app crashes when started.

We are generally fine now, as we managed to reduce app size by using only Android Link Mode set to SDKOnly, and turning off r8 link tool.

Hi Tomislav,

Thx for your feedback. I'll forward that feedback internally, but it's good that you're good for now.

Thx and greetings


Login or Signup to post a comment