Start a new topic

Android crash due to "No virtual method setLightEstimationMode"


I'm trying to implement the InstantScenePickingActivity sample into my existing project, where I have used ARCore before. Now, as soon as the InstantScenePickingActivity is launched, the app crashes due to:

E/AndroidRuntime: FATAL EXCEPTION: main
    Process: com.snapandtrack, PID: 3859
    java.lang.NoSuchMethodError: No virtual method setLightEstimationMode(Lcom/google/ar/core/Config$LightEstimationMode;)V in class Lcom/google/ar/core/Config; or its super classes (declaration of '' appears in /data/app/com.snapandtrack-6Xts_2nhfQog8FfEtbUYww==/base.apk)
        at com.wikitude.common.arcore.internal.d.m(Unknown Source:9)
        at com.wikitude.common.arcore.internal.d.a(Unknown Source:36)
        at com.wikitude.common.arcore.internal.NativeArCoreInterface.start(Unknown Source:2)
        at Method)
        at Source:2)
        at Source:57)
        at Source:10)
        at Source:2)
        at Method)
        at Source:2)
        at$2$ Source:8)
        at android.os.Handler.handleCallback(
        at android.os.Handler.dispatchMessage(
        at android.os.Looper.loop(
        at java.lang.reflect.Method.invoke(Native Method)

I have tried to make everything match the sample, but the app keeps crashing.

Hope you can help.

Thank you and kind regards,


Creating an InstantTracker with configuration.setSMARTEnabled(false) works though.


Can you please provide the following details:

  • Which version of the SDK are you using?
  • Are you using any of our Extensions (Cordova, Xamarin, Unity)? If yes, which version are you using?
  • What device does this happen with (model details and OS version)?
  • Is this happening with the sample app or in your own app? If it happens with your own app, does the unchanged sample app work on your device?

Thx and greetings



I'm using Android Native SDK 8.9.0 without any other extensions.

It happens on my Samsung Galaxy S10e running Android 9. But the sample app works fine on that device.

Once I try to implement it into my own app, it crashes.

Previously I was using ARCore and now I want to switch to Wikitude SDK in my app. The thing is, when I create a InstantTracker with SMART set to disabled, the InstantScenePickingActivity in my own app launches. But I made sure that I'm not using ARCore or anything before creating the InstantScenePickingActivity.

Hi Alexander,

We had a user reporting the same error in our Xamarin extension 2 months ago:

The problem could come from one of the dependencies of your project that requires an AR Core version higher that 1.5, which we do not support yet.

Try to check the AR Core version of your dependencies and your device and remove it if needed.


Aitor Font.

Login or Signup to post a comment