Start a new topic

DllNotFoundException: Unable to load DLL 'UnityAndroidBridge'

When building my unity app for 64 bit I get this error: 

(Filename: currently not available on il2cpp Line: -1)

2019-06-27 17:16:49.517 28889-28917/? E/Unity: DllNotFoundException: Unable to load DLL 'UnityAndroidBridge': The specified module could not be found.

      at Wikitude.AndroidWikitudeBridge.UnityWikitudeBindings_StartWikitudeNativeSDK () [0x00000] in <00000000000000000000000000000000>:0 


Please advise.


1 person has this problem

Hi,


Please provide the following details:


  • Which version of the SDK are you using?

  • What Unity version are you using?

  • Is this happening with the sample app or in your own app? If it happens with your own app, Does the sample app work on your device?


Thx and greetings

Nicola


Hi Nicola,
1. 8.2.0

2. unity 2019.2.0a11

3. It's happening both on my app and the sample app.


Thanks,

Tamar

Hi,


Thx for providing the details. Does the same also happen with the latest SDK?


Thx and greetings

Nicola

Hi Nicola,
I've checked the latest version 8.5.0
The issue above does not occur on both sample app and mine,
However I'm having a new error on both apps:
 


2019-07-01 12:04:35.769 12114-12128/? E/Unity: Could not check if tracking can be started because the InstantTracker doesn't exist!

     

    (Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 35)


Please advise,

Tamar

I forgot to mention this error occurs in sample app when choosing:

INSTANT TRACKING -> Simple


Thanks,

Tamar 

HI, this also happen for me, Unity 2017.3.1 and Wikitude version 8.5.

Just some note, this does not work only on my acer tab (android version 4.4) and it works on my xiaomi phone (android 7).

Can you help us with this?

I also try to download wikitude app on my acer tab and it works so I have high hope for wikitude

And also it is x86 arm device. I tried to unzip my apk and I do not find libUnityAndroidBridge.so for x86 version like in other version (v64 and armv7). Is it because of this?

Hi, 


Regarding this error: "Could not check if tracking can be started because the InstantTracker doesn't exist!". Please make sure that you have a valid license key and that the platform is set to either iOS, Android or UWP.


Regarding x86 support on Android, we decided to remove it in the 8.4 release, as we mentioned in the migration notes. This decision was made because Unity announced they will be deprecating and removing x86 support for Android from Unity completely in the 2019.x release cycle. More information can be found in this blog post.


Best regards,

Alexandru

After upgrading to Wikitude version 8.5.0 all issue are resloved.

Login or Signup to post a comment