Start a new topic

Manifest merger failed in Unity+Android

Hi,


When building an Android APK in Unity (version 2018.3.8f1 Personal) I get the following error:


Manifest merger failed : uses-sdk:minSdkVersion 16 cannot be smaller than version 19 declared in library [:android_component:] C:\Users\user\.gradle\caches\transforms-1\files-1.1\android_component.aar\9e395af1b3e2a3df85a450fd87b8cce6\AndroidManifest.xml as the library might be using APIs not available in 16


I can build any Android APK without any problem, but as soon as I import Wikitude package (version 8.3.0) the build fails.


Thanks


Hi,


Thank you for letting us know that the issue is resolved. We'll make sure to add this to the documentation.


Best regards,
Alexandru

Solved!


In Player Settings > Other Settings > Minimum API Level, change from "Android 4.1 Jelly Bean (API level 16)" to "Android 4.4 KitKat (API level 19)"

Login or Signup to post a comment