Start a new topic

Re-Enabled InstantTracker not working with SMART enabled

Disabling the InstantTracker component and then re-enabling it at runtime generates the following error and does not track when calling CanStartTracking():

Could not check if tracking can be started because the InstantTracker doesn't exist!

This error is expected while the tracking is disabled but is generated in Editor and on iOS device when SMART is enabled and the tracker has been re-enabled.

This appears to be related to topic


Wikitude 8.2 SDK for Unity

Unity 2018.1.3f1 on OSX

IOS 11.0

Steps to reproduce:

1) Run Instant Tracking - Simple scene

2) Initialize Tracking

3) Reset

4) disable InstantTracking component and then re-enable

5) Initialize Tracking


Thank you for reporting this issue. We've found the problem the it should be fixed in the next version of the SDK.

Until then, the only workaround is to destroy and re-create the InstantTracker component.

Best regards,

Hello Technical Support,

I'm also stuck with this problem.
It looks problem were solved but next SDK doesn't looks available.
Is it possible to download current stable build?

1 person likes this

I am also facing this issue with Instant Tracking impossible to enable back once SetActive(false). This is a very disturbing issue. @Alexandru  can you tell how you'd Destroy and recreate the component ?


I am using Unity 2018.3.6f1 with the latest wikitude version. 

1 person likes this

I have managed to make it work by reloading the scene with "SceneManager.LoadScene(SceneManager.GetActiveScene().name);" if that helps you. @Tetsuya Matsukata In my case, it's okay for me as I still need SMART because of ARCore. I tried Destroying the components and all but still these errors. Try this if you want method and see if it suits your case.

Thank you very much @Etienne Silvio. But my case is same as yours because ARCore support is needed. 
 I'll try Destroying method as your advice. 
And wait for Tech's answer.
Thanks again!


Wikitude SDK 8.3.0 was recently released and it should fix this issue. If it doesn't, please let us know.

Best regards,


Dear Alexandru,

Thank you for your help. Now I have another issue.  I have noticed that you have added the OnInitializationError() event to the ImageTracker. With this version, my ImageTracker never seems to initialize. It's always giving me an error and my ImageTracker is not working. In my scene I have got Image Tracking and an Instant Tracking which are toggled by Setting one active at a time. Now my Image Tracker is not working at all after the update. 

Please help ASAP.



Can you please post the error that you are getting? It might be a licensing issue, so please check that the License Key and Bundle Identifier values are set correctly. If you are having these issues in the Unity Editor, please make sure to switch the platform to one of the licensed platforms.

Best regards,


Login or Signup to post a comment