Start a new topic
Solved

iOS Location Services authorization

Hello,


I use Wikitude JavaScript API for iOS. When I call WTArchitectView start() method I get the error: "Not all required APIs are authorized." I found that this error appears when my app has Location Services authorization is set to "Always". If I change this setting to "While Using the App" error is gone.

The problem is that functionality of my app requires Location Services set to "Always". Please let me know how can I use Wikitude in this mode?


Thanks


Hi Jack,

As the one time fee license doesn't entitle you to get free upgrades, you'd need to purchase a license upgrade. Please send an email to sales@wikitude.com to get further details.

Greetings

Nicola

 

Thanks Daniel.  Presumably we can't use this with our license?  (which is a one-time license)?


Jack

Good morning Jack,



you are correct: setting the authorization status to Always is currently not supported by the Wikitude SDK. It will, however, be supported with the next release which is scheduled to arrive soon.


Meanwhile, I can offer a pre-release package that should include this functionality.


You may download it here.



- Daniel

Login or Signup to post a comment