Start a new topic

Epson Moverio BT-200 crash

Hi there. I'm playing around with the examples for Epson Moverio on a BT-200 and I'm seeing a crash. When viewing a POI example, for instance, if I then pause the application, by pressing the home button, the app crashes. Android studio gives the following info:


05-12 11:03:06.218 9775-9775/com.wikitude.sdksamples E/AndroidRuntime: FATAL EXCEPTION: main

                                                                       java.lang.NullPointerException

                                                                           at com.wikitude.common.services.sensors.internal.d$a.b(ProGuard:256)

                                                                           at com.wikitude.common.services.sensors.internal.d$2.onSensorChanged(ProGuard:320)

                                                                           at android.hardware.SensorManager$ListenerDelegate$1.handleMessage(SensorManager.java:580)

                                                                           at android.os.Handler.dispatchMessage(Handler.java:99)

                                                                           at android.os.Looper.loop(Looper.java:137)

                                                                           at android.app.ActivityThread.main(ActivityThread.java:4424)

                                                                           at java.lang.reflect.Method.invokeNative(Native Method)

                                                                           at java.lang.reflect.Method.invoke(Method.java:511)

                                                                           at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)

                                                                           at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)

                                                                           at dalvik.system.NativeStart.main(Native Method)



Is this a problem with the latest SDK? it seems to happen whenever the AbstractArchitectCamActivity on Pause gets called.


Thats great.


Thanks Alex.

Hi Simon,


thank you for reporting this issue. It seems to be an issue that is only happening on the epson BT-200.

A fix for this will be included in the next SDK release.


Best Regards,

Alex

Login or Signup to post a comment