Start a new topic

Loading world from url keep shows "Loading..."


I am using New Studio (Beta), I export my collection,

1 - I copied files into my project, I load world from device, it's working fine

2 - I uploaded same files into my own hosting, I tried to load it by url, it keep showing 'loading...' on screen, then I tried to open same url in wikitude app, and result is the same

this is url to my hosting

1 person has this problem


I am really exhausted, my issue still exists, it's the simplest scenario ever, I have recorded a video, and provided link to sample, but still I don't get answer if it's a bug on your side or I am missing something.

1. create a collection and target in
2. export project
3. upload exported project to my site
4. open wikitude app
5. enter url in developer menu

Expected result:
- loading world and detecting target

Actual behavior
- It keep showing "Loading..."

Would you please ensure that same scenario is working on your side, if it's working on you side something is wrong with my work , other wise it's a bug


Hello Reza,

Uploading files on your own server should work. Are you following exactly the steps described in the article here? Also, since you are uploading them to your server, please make sure that the files are publicly accessible when you load them.

Regarding the Wikitude app, we are currently updating it and once this is done, we will let you know so that you can test your New Studio project with it.



Hi Eva

Yes, I have done exactly what is mentioned in that link, 
After hours of investigation I solved it by this way

1. Changing "isCloud" to true in project.js

2. Adding ClientToken in project.js

Then it will work in both Wikitude app and also my own application.

Would you confirm this solution with technical team?


we tested your project on our servers and we don't have any problems with it. You can test it by opening the URL in the SDK Examples app: (be aware that this link is only valid for 14 days). We exported your project unzipped the result and uploaded the files on our server. There must be an issue on your server.




Thanks for response and help, yes the url you provided is working, but how can I investigate what is wrong with my own host, I already tried 2 different hosts and the result is the same (I did same as you, I downloaded the zip file, extract, copy to host), I would appreciate if you give me some hints how should I find the issue, also I can give you ftp access to the hosting files if it's needed.


This is the original copy without any changes

and this is the modified one as I described it on above

We noticed that your server returns an error when loading the tracker file because of the wtc file extension:

We will improve the error logs on our side to identify such errors easier in the future. Thank's for the report.

Thanks for fast response, 
I add "binary/octet-stream" mime type for wtc files in my hosting, now if I get "" browser doesn't show error and start downloading file,
But in wikitude app I get "Connection Error" message, 
Is "binary/octet-stream" correct mime type? (Also I tried text/html )

Also I tried "application/octet-stream" as MimeType and same error

binary/octet-stream should be the correct MimeType

Now it's "binary/octet-stream" and still I get "Connection Error" message on Wikitude app,

Please run through each file of your project and check if you are able to download it via the browser. Maybe there you have similar issues with other files.

Thanks, Ok, I did that, I went trough all files and file types in all folders and they are retrievable from browser and postman tool.

Hello Reza,

Your 'solution' what is actually doing is bypassing your server and it is loading everything on our server. This is something that will no longer be available so it will not work. May I ask which SDK version are you testing with?



Login or Signup to post a comment