Start a new topic

sdk 6.0 image recognition ade.js error

Hi, I'm trying to migrate to new sdk but when I try to use AR.TargetCollectionResource I get this ade error:

"Uncaught TypeError: Cannot read property 'createTargetCollectionResource' of undefined" at class call line.

The address of wtc file is correct, I tried also an absolute url. 

In fact it happens even if I load sdk sample too, so It seems not to be a my code problem.

Some suggests?

Best regards

Antonio Petruzzella

Hi Antonio,

Since you have already been using a previous version of our SDK, please try first to clean your project and/or delete the generated build folders and then rebuild it with our new SDK 6.



Hi Eva,

I'm not using an Android project or other, I'm using sdk demo APP. World works fine, but ade gives this error. In another case classical method gives same error, but nothing changed in code from 5.3 that doesn't give.

Another user seems like having same issue:



Hi Antonio,

Our technical team is investigating on this issue and you should receive a response soon. Since you are also following the forum post above please check this from now on, so it will be easier for us as well to inform people with similar issues.



Hi Antonio,

ade.js is not updated to the new API at the moment. We recommend debugging using Safari or Chrome web inspector.

Best regards,


Login or Signup to post a comment