Start a new topic

sample cordova wikitude sdk 6.0 does n't work

Hi there, 

Congratulations for the new SDK and SLAM feature, was really looking forward to this!

I try to build sample app using cordova plugin. But it does n't work.

If I press the all Button in index.html nothings happens.... except for world url button.

I have download the new SDK 6.0 and also the sample app resource from github.

It does n't work both android and iOS. 

Hope you can give the solution...

Thank you

Hi Budi,

If you have generated a cordova project with a previous sdk version then please try first to clean your project and/or delete the generated build folders. Then you can follow the instructions here regarding how to create a new cordova project. Please keep in mind that if you wish to try the new Instant Tracking feature in your own app you need to reach out to to request your key.


Hi Eva,

Yes I have build new one. But nothing happen when I press button option in index.html.

Maybe the indes.js on sample app is wrong code

please check or provide the sample link for cordova

thank you

Hi Budi,

We have tested our new SDK 6 with all our extensions. Please make sure that you have downloaded the latest version from here and that you are testing our sample without any modifications from your side.




I've also created a sample app with cordova and isn't working so far. I've created it from wikitude-cordova-plugin-samples-master github repo.

My phonegap version is 6.4.3

My cordova version is 6.4.0 (phonegap cli)

I've tried with android studio, Xcode and phonegap app over an iphone 7.

I've loaded the hello.html from dropbox.

Nothing happens.

If you have some advice...

Greetings and thank you!


What is the hello.html file you are referring to, the index.html file? Also, could you give more details regarding what it is that it is not working? Are you getting any error? Are you able to launch the app but the augmentation is not working?

Have you already refered to our documentation regarding how to set up a Cordova project with our SDK?



Sorry I meant index.html file.

The issue is that I create and buid the sample, then I launch it from the PHONEGAP APP (I mean the means that lets you launch an application in a real device through the LAN without installing it physically) and when I try to launch one of the examples, for instance "IMAGE ON TARGET", an alert window pops up showing the following text: "index.html  null". 

I don't know if it's a matter of the PHONEGAP APP, configuration or whatever... but it seems to work ok trying with other applications so I don't know what to do. Any advice?

Thank you


I think that your problem is that you are not loading the files properly. You mentioned above that you are putting your files in dropbox and as far as I know, in order to be able to access them publicly you need to put the correct link provided by dropbox. What you can also do is try and host everything locally and see if that works for you.



Maybe there's something that I am not understanding properly. If I set up the sample app as follows:

$ ./ -d ~/Path/Where/The/App/Should/Be/Created -ios true -android true

Do I need to pass an url to the application?

When I check the project folder I find the ARWorlds inside. ¿?

So why the applicaction doesn't find the ARWorlds?

Thank you for your time!


No you do not need to pass a url. When I said that it could be a problem with how you are loading the files I mean your whole project. Are you storing everything locally or are you uploading them on a server? Based on how you store those files you should then be careful when you define the absolute paths of your files.



Finally I solved the problem by installing the app directly on the device physically through Xcode. It was a matter of the phonegap developer app that doesn't accept this plugin. Don't know why.

Thx a lot for your help


Login or Signup to post a comment