Start a new topic

Android Studio - Cannot build examples


When I try to build the examples on Android, or try to start my own project following the instructions on your website (i.e. copying wikitudesdk.aar into app/libs and updating the gradle) I get a rendering problem on the layout file where the ArchitectView resides (instantiated with 

<com.wikitude.architect.ArchitectView android:id="@+id/architectView" android:layout_width="fill_parent" android:layout_height="fill_parent"/>

Please find attached the full error message.

Any ideas?

Thank you,


(107 KB)


This question is more related on how to build your Android app than to any functionality of the Wikitude SDK. Please check e.g. in stackoverflow for getting details on how to set up the system.



Are you sure? I have several projects going on Android that used to work perfectly until one month ago, now I have updated Android Studio and ALL of them have the same behaviour, they can't find architect in java.library.path even though I haven't touched anything since. And I have a stock installation of Android Studio that, I repeat, worked perfectly until one month ago.


Update: I have switched to Windows, did a fresh install of Android Studio, followed exactly once again the instructions given in your tutorial, but still no luck.

Now I get this error:

java.lang.VerifyError: Expecting a stackmap frame at branch target 12

on the layout view where I try to insert the ArchitectView and the app crashes.

Can you please help?

Thank you,


Hi Paolo,

Again - this question sounds more like a question related to the Android set-up than to any functionality of the Wikitude SDK. Please check e.g. stackoverflow or Android forums for this error message.




Android Studio setup is stock, both on Mac and Windows machines, I had no trouble whatsoever using other libraries in other projects. I have followed exactly the instructions on your website and I can't even place an ArchitectView. If this is the level of support you provide, it makes me really wonder if we made the right choice buying your SDK.

Thanks anyway.

Hi there!

Really hard to find out what's the issue without sitting next to you or have your full project sources.

I just testet using latest Android Studio and import the SDK Sample application that is part of the Wikitude "Android JavaScript API". Ensure to have required Android SDK and build-tools version installed. Having that set you can deploy the application directly to your Android device. Note that you can't run it on a simulated device.

We also bundle the build apk with the SDK Sample app, which was generated using gradle on our build server. That way we ensure to have a stable sample and SDK.

I hope this helps somehow.

Best regards

Thanks for your help, now I have somehow managed to progress using the sample app as a basis.

However, what I get now when I enter the ArchitectView is a black screen with the TRIAL watermark overlaid. I'm using one of your sample html assets as a test using the trial password you have sent.

Whay do I get that? What am I doing wrong?

By the way, can you provide a template empty app for Android with just a simple activity including an ArchitectView? I think this would be really useful for a lot of developers.


Please start investigation using the official SDK sample app.
The black screen may be related to a missing or unhandled (runtime) permission.
Also check on more than one device to ensure it is not a hardware specific issue.

best regards

Hi Andreas.

I have started a new project from scratch and now the black screen is gone. What puzzles me is that I have followed the same exact steps as before, when it was not working... 

But now I have another problem: buttons in my custom HTML don't seem to work.

Whenever i tap on the architectView I get 

ViewRootImpl: ViewPostImeInputStage processPointer 0

and tap messages don't go through.

Any idea?


Please use HTML Drawables only for very basic HTML layouts. Clicks within the HTML will only fire when clickThroughEnabled is set. In any case I highly recommend to just define an overall clickListener and avoid buttons inside the div. Also note that HTMLDrawables may look different, depending on the OS version you're using it. Using ImageDrawables and Labels is always a better choice.

Best regards

I haven't been clear in my previous email, my fault, I'll try to explain better. 

In my HTML I need to have a back button always present top left in order to close the ArchitectView and return to the previous screen. It is a <div> with a png image that I use to communicate from JS to the native app using the urlWasInvoked method.

The equivalent in iOS works perfectly; in Android, when I tap on the ArchitectView (not only on this specific div) I get ViewRootImpl: ViewPostImeInputStage processPointer 0 on touchstart and ViewRootImpl: ViewPostImeInputStage processPointer 1 on touchend, and the event doesn't go through, so urlWasInvoked is never called.

Hi Paolo,

Does this issue also occur when customizing an existing Sample application? Maybe the issue is CSS related so that the div on top consumes the click-events. Have a look at the POI samples div styles.
In case the issue persists please create a small sample so that we can investigate internally.
Also provide details about the OS version, devices and SDK Version you encountered the issue and send it to with subject "Forum Topic 5000080903" 

Hi Paolo

this issue with the touchstart event is fixed in SDK 6.0 so please try it with this version.

Best regards,


Login or Signup to post a comment