Start a new topic

Nexus 7 and openSSL Upgrade

Nexus 7 and openSSL Upgrade


We have updated our application with the upgrade version of wikitude for the openSSL recently and now we have noticed that the AR does not recognise the object by using Nexus 7 (Android version 6.0).

We have tested by taking the new version of wikitude and we placed back the old version without openSSL upgrade and we have seen that the AR is working correctly with Nexus 7 (Android version 6.0).

Are there any issue similar to our case and any solutions?

Thank you!

Hello Nakasha,

Can you please send over your whole AR experience (.html, .css, .js, files, assets, target images) so that we can test internally? Also, just to verify, were you using Wikitude Cordova 5.1.4 before?

Thank you


Thank you for your reply.

We were using wikitude cordova plugin 5.1.4?bofore openSSL upgrade? and we replaced it to the one with the openSSL upgrade.

Here is our AR experience and please let us know if you need any additional information. 


 * start AR


function arStart() {

    //HTML pass for AR screen

    var request_ar = AR_PATH;

    var requests = ;


    //AR type ? "geo","2d_tracking"

    request_ar = AR_PATH_IMG + "?timestamp=" + new Date().getTime();

    var ar_type = ;


    ar_app.initialize(request_ar, ar_type);


var ar_app = {

    // Url/Path to the augmented reality experience you would like to load

    arExperienceUrl: "",

    // The features your augmented reality experience requires, only define the

    // ones you really need

    requiredFeatures: ,

    // Represents the device capability of launching augmented reality

    // experiences with specific features

    isDeviceSupported: false,

    // Additional startup settings, for now the only setting available is

    // camera_position (back|front)

    startupConfiguration: {

        "camera_position": "back"


    // Application Constructor

    initialize: function(path, type) {

        this.arExperienceUrl = path;

        this.requiredFeatures = type;



    // Bind Event Listeners


    // Bind any events that are required on startup. Common events are:

    // 'load', 'deviceready', 'offline', and 'online'.

    bindEvents: function() {

        document.addEventListener('deviceready', this.onDeviceReady, false);


    // deviceready Event Handler

    onDeviceReady: function() {

        ar_app.wikitudePlugin = cordova.require("com.wikitude.phonegap.WikitudePlugin.WikitudePlugin");

        ar_app.wikitudePlugin.isDeviceSupported(ar_app.onDeviceSupported, ar_app.onDeviceNotSupported, ar_app.requiredFeatures);


    // Callback if the device supports all required features

    onDeviceSupported: function() {

        ar_app.isDeviceSupported = true;










    // Callback if the device does not support all required features

    onDeviceNotSupported: function(errorMessage) {

        _alert("Device is not supported");


    // Callback if your AR experience loaded successful

    onARExperienceLoadedSuccessful: function(loadedURL) {


         * Respond to successful augmented reality experience loading if you

         * need to



    // Callback if your AR experience did not load successful

    onARExperienceLoadError: function(errorMessage) {

        _alert('Loading AR web view failed: ' + "");


    // This function gets called if you call "document.location =

    // architectsdk://" in your ARchitect World

    onUrlInvoke: function(url) {

    if (url.indexOf('quit') > -1) {

            if (!ua.isIOS) {



            setTimeout(function() {


            }, 500);

        } else if (url.indexOf('close') > -1) {

            //Close AR

            if (ua.isIOS) {


            } else {


                setTimeout(function() {


                }, 1000);


        } else if (url.indexOf('vibrate') > -1) {


        } else if (url.indexOf('restart') > -1){

        //Restart the application when there is no GPS information by AR






            _alert(url + "not supported");






Additional info,


//version for framework and platform.

Cordova 6.2.0

iOS 3.9.2

Android 5.1.1


//call of wikitude plugin



//updated plugin version.

5.1.4 -> it's not working.

5.2.0 -> it's not working.

Hi Nakasha,
It sounds strange that the update to SDK 5.2.0 broke your Architect World. Can you please share a demo Cordova project with us so that we can investigate your issue further? THX!
You could also implement the onLoaded/onError callback for your AR.ClientTracker in order to verify that the tracker could be loaded.

Best regards,



I also have exactly same problem on Nexus 7. I checked the loaded event and everything was working correctly. I tested with many devices and it's working well(Nexus 5 with Android 6.0, Galaxy Note with Android 6.0.1 and Galaxy Tab with Android 5). I tested with Nexus 7(Android 6.0.1 - latest version). Please check it... Thank you.


Hi Joshua, Nakasha,
I don't quite understand your problems. What is it exactly that is not working? Is the Architect World not loaded or assets from the Architect World?

Best regards,



Architect World and WTC file are loaded correctly but when I scan image, AR(IR:Image Recognition) does not recognise image. I tested same App in different devices and it's working well(IR). Thank you.

Hi Joshua,
I'm not sure if I understood your message correctly. Are you still experiencing problems recognising a target image or is your problem solved?

Best regards,



I also tested with Nexus 5(latest Android version - it's same Android version) and it's working well. Only Nexus 7 has IR problem. I checked with console log and I got WTC loaded event but IR is not working. Thank you.

If you get a log saying that the .wtc is loaded, then the OpenSSL update can't be an issue as this would be used to download the .wtc. Are you using our 'final' release of SDK 5.2.0, downloaded from our main download page or do you use a pre-release version that was linked in our forum?

Best regards,



So I tested with final release version SDK 5.2.0 and I got same result(It's not working). I also tested loading WTC file from web(not local) but it's also same result. I also tested with Nexus 5(Latest version) but it's working well. Thank you.

Hi Joshua,
I created an internal bug report and we will provide more information once we started investigation.

Best regards,



Any news on this?  We are facing the same issue on Nexus 7. But because other devices may be affected as well, we have rolled back to 5.1.4.



Hi Andreas

We are experiencing this issue as well. We use Nexus 7 to run a lot of our events with clients and it's preventing us from releasing a new Android version on the Google Store.

Could you provide an update on ETA for a fix as this is now impacting on our business?

Many thanks

Maria Carmo, on behalf of Peter Barker/Wildgoose
Login or Signup to post a comment