Start a new topic

XCODE archive error. clang: error: linker command failed with exit code 1 (

XCODE archive error. clang: error: linker command failed with exit code 1 (


Hi Budi,

There is a new release for Cordova (Version 5.1.4-3.2.1) that you can download from our page and see if your issue still remains.

I hope this should help.

Hi....

I got error when I try make archive in xcode

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

what is the problem?

 

Ld /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/arm64/Interact-AR normal arm64

    cd /Users/infinite/Documents/interact10/platforms/ios

    export IPHONEOS_DEPLOYMENT_TARGET=6.0

    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch arm64 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS8.1.sdk -L/Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/BuildProductsPath/Release-iphoneos -L/Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin -F/Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/BuildProductsPath/Release-iphoneos -filelist /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/arm64/Interact-AR.LinkFileList -dead_strip -weak_framework CoreFoundation -weak_framework UIKit -weak_framework AVFoundation -weak_framework CoreMedia -weak-lSystem -ObjC -fobjc-arc -fobjc-link-runtime -miphoneos-version-min=6.0 -framework AssetsLibrary /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/BuildProductsPath/Release-iphoneos/libCordova.a -framework CoreGraphics -framework MobileCoreServices -lWikitudeSDK -lWikitudeSDK-simulator -framework Accelerate -framework AVFoundation -framework CFNetwork -framework CoreLocation -framework CoreMedia -framework CoreMotion -framework CoreText -framework CoreVideo -framework Foundation -framework MediaPlayer -framework OpenGLES -framework QuartzCore -framework Security -framework SystemConfiguration -framework UIKit -lc++ -lz -Xlinker -dependency_info -Xlinker /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/arm64/Interact-AR_dependency_info.dat -o /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/arm64/Interact-AR

 

ld: warning: ignoring file /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK-simulator.a, missing required architecture arm64 in file /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK-simulator.a (2 slices)

ld: in /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK.a(array_utils.cc.o), could not parse object file /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK.a(array_utils.cc.o): 'Invalid value', using libLTO version 'LLVM version 3.5svn' for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

Ld /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/armv7/Interact-AR normal armv7

    cd /Users/infinite/Documents/interact10/platforms/ios

    export IPHONEOS_DEPLOYMENT_TARGET=6.0

    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch armv7 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS8.1.sdk -L/Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/BuildProductsPath/Release-iphoneos -L/Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin -F/Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/BuildProductsPath/Release-iphoneos -filelist /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/armv7/Interact-AR.LinkFileList -dead_strip -weak_framework CoreFoundation -weak_framework UIKit -weak_framework AVFoundation -weak_framework CoreMedia -weak-lSystem -ObjC -fobjc-arc -fobjc-link-runtime -miphoneos-version-min=6.0 -framework AssetsLibrary /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/BuildProductsPath/Release-iphoneos/libCordova.a -framework CoreGraphics -framework MobileCoreServices -lWikitudeSDK -lWikitudeSDK-simulator -framework Accelerate -framework AVFoundation -framework CFNetwork -framework CoreLocation -framework CoreMedia -framework CoreMotion -framework CoreText -framework CoreVideo -framework Foundation -framework MediaPlayer -framework OpenGLES -framework QuartzCore -framework Security -framework SystemConfiguration -framework UIKit -lc++ -lz -Xlinker -dependency_info -Xlinker /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/armv7/Interact-AR_dependency_info.dat -o /Users/infinite/Library/Developer/Xcode/DerivedData/Interact-AR-dbnwtwmtlvkwwbdcwspqovdzuige/Build/Intermediates/ArchiveIntermediates/Interact-AR/IntermediateBuildFilesPath/Interact-AR.build/Release-iphoneos/Interact-AR.build/Objects-normal/armv7/Interact-AR

 

ld: warning: ignoring file /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK-simulator.a, missing required architecture armv7 in file /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK-simulator.a (2 slices)

ld: in /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK.a(array_utils.cc.o), could not parse object file /Users/infinite/Documents/interact10/platforms/ios/Interact-AR/Plugins/com.wikitude.phonegap.WikitudePlugin/libWikitudeSDK.a(array_utils.cc.o): 'Invalid value', using libLTO version 'LLVM version 3.5svn' for architecture armv7

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

 

 

 

Hello Budi,

Can you please tell me what SDK version you are using and if you are using any plugins and what version of iOS you are working on? Please keep in mind that some of our SDKs require iOS 8 or a later version, such as our Native SDK since the Wikitude Native SDK is configured as dynamic framework to support ObjC and Swift.

Thanks

 

Hi Eva,

 

I am using xcode 6.1.1 and use wikitude sdk 5.1.0. Cordova plugin I download from http://github.com/Wikitude/wikitude-cordova-plugin
 

 

I just try use the latest xcode 7.3.1 and still error.

 

I think the problem is from wikitude plugin.

do you have a new wikitude plugin?

 

thanks 
Login or Signup to post a comment