Start a new topic

The radar and POI labels are not visible (does not show) on the AR screen

The radar and POI labels are not visible (does not show) on the AR screen



We are having some issues about the appearance of the rader and POI labels.

Sometimes the radar and POI labels are not visible (does  not show) on the AR screen.


We  are using Wikitude cordova plugin 5.1.4 and all the source?code and data regarding AR are placed in our server.


We have checked data but it seems there is no problem as below;


AR.radar = true;

World.initialized= true;


We have seen that AR.context.onLocationChanged?is excuted without any problem on the background 

and the GPS update is working correctly. 


Not only when we start our application, but also we have seen the same issue when we repeat the action of opening and closing the AR.


As we could not find any reason why sometimes the radar and POI labels are not shown, now we are wondering what we should confirm more.


Are there any suggestion?


Thank you!





Both, Radar and POI Markers are using AR.ImageResources. Implement onError/onLoaded callback-function of the AR.ImageResource to find out whether assets were loaded successfully. Also ensure so keep asset's filesize low to achieve minimum latency. 
Sometimes it is worth loading used ressources upfront and even display a loading indicator in the meantime. That way you can e.g. laod radar and other assets and set up the scene once all assets were loaded.

Hope this helps.
Best regards

Hi Andreas,

Thank you for your prompt reply.

We have checked the status of AR.ImageResource.

We have seen;
1. In the case of the rader is displayed correctly --->the onLoaded event can be fired
2. In the case of the rader is NOT displayed;
--->tneither the onLoaded nor the onError events fire

Are there any way to reload assets when we get isLoaded()==false?

?we have tried to use new AR.ImageResource(path_of_image); but we could not get the expected result.?

Looking forward to hear your reply soon.

Thank you!



Hi there!


Note that both radar and ImageDrawable use AR.ImageResource, so Error/Success callback handing is same.
Can you please try hosting the files on a different server and see if the issue still remains. I can just imagine that the loading process times out under certain curcumstances when loading from your current file hosting server.

Best regards


Thank you for your reply.

We have tried it by placing the image files inside of the app and we could not see the expected result.

So it seems the problems is not from the server time out. 

Also we have reproduced the same issue by using 6.2 additing radar with wikitude sample app (which means that we couldnt show the image of the rader and the back ground color of the labels )

Do you know any functions to restart the AR world?

Thank you!


like this...

Sounds as if the imageAsset is either encoded in a wrong way or the asset is to large in dimension/filesize.

Please try using another png file as background and test it in sample app upfront.

Answering your "how to restart an experience" question:
You can close the experience and launch a different one in your native iOS/Android code or properly destroy your assets with the .destroy() function per object or go for the quick'n'dirty approach and call AR.context.destroyAll() in JS and reset all of your "World environment" afterwards. Note that also resource files stored in variables are 'wiped away', although you can still access them - Therefore ensure that all your ressources are reloaded after calling AR.context.destroyAll()

Best regards
Login or Signup to post a comment