Start a new topic

Black screen with moverio BT-200

Black screen with moverio BT-200


Ok. So, at the moment, I use the android SDK (4.1.1).

Good luck for the release ! And thanks a lot for your answers !

Hello Alaric,

We are currently working on a release and we are actually on the final stage. However, we cannot yet give a specific release date but I will let you know when it is ready.

Thanks!

Thanks a lot !

 

I have a last question. When will you propose the update for Epson SDK ?

Do you think it will be released before June ?

 

Thank you very much for your help !

Hello Alaric,

You can find older versions for Android and iOS on our developer page. For Epson we do not have the version there, but if you need the latest stable 4.x version then we can send it once the SDK is updated to SDK 5.

Thanks!

Ok, thanks for your reply !

 

I tried to do tutorials with Wikitude SDK 3.3.2 for android ( found in this thread https://support.wikitude.com/support/search/topics?term=Download+orevious+version) and it's work on my phone and on Moverio BT-200.

So, I would like to know if it's possible to access older SDK versions of Wikitude (for Android (after 3.3.2) and for Moverio BT-200), please ?

Hello Alaric,

We are aware that there are some issues with Moverio BT-200 and our developers are currently working on that. As soon as there will be an update I will inform you. Thank you for your patience.

Hi !

 

I try to develop an application for Epson Moverio BT-200 and I have some problems. I use Android Studio with gradle 1.3.0.

I try to do http://www.wikitude.com/external/doc/documentation/latest/epson/setupguideepson.html#setup-guide-epson and http://www.wikitude.com/developer/documentation/epson#_48_INSTANCE_SUygKVgNX0m5_=clientrecognition.html%23client-recognition (image on target) tutorials. I can load my application, but when I load this, I have a black screen with words "trial".

 

In my logcat, I have this message :

05-10 10:46:59.445 834-834/com.maritimconnect.orange.essaiswikitudelunette I/Android Callback: ARchitect Build: 616fc4d
05-10 10:46:59.976 834-869/com.maritimconnect.orange.essaiswikitudelunette I/Android Callback: Service: 'sensors' already running
05-10 10:47:00.117 834-834/com.maritimconnect.orange.essaiswikitudelunette D/libEGL: loaded /system/lib/egl/libGLES_android.so
05-10 10:47:00.125 834-834/com.maritimconnect.orange.essaiswikitudelunette D/libEGL: loaded /vendor/lib/egl/libEGL_POWERVR_SGX540_120.so
05-10 10:47:00.132 834-834/com.maritimconnect.orange.essaiswikitudelunette D/libEGL: loaded /vendor/lib/egl/libGLESv1_CM_POWERVR_SGX540_120.so
05-10 10:47:00.132 834-834/com.maritimconnect.orange.essaiswikitudelunette D/libEGL: loaded /vendor/lib/egl/libGLESv2_POWERVR_SGX540_120.so
05-10 10:47:00.226 834-834/com.maritimconnect.orange.essaiswikitudelunette D/OpenGLRenderer: Enabling debug mode 0
05-10 10:47:00.281 834-834/com.maritimconnect.orange.essaiswikitudelunette D/dalvikvm: GC_FOR_ALLOC freed 208K, 5% free 7575K/7943K, paused 14ms
05-10 10:47:00.281 834-834/com.maritimconnect.orange.essaiswikitudelunette I/dalvikvm-heap: Grow heap (frag case) to 7.910MB for 460816-byte allocation
05-10 10:47:00.304 834-879/com.maritimconnect.orange.essaiswikitudelunette D/dalvikvm: GC_FOR_ALLOC freed 2K, 6% free 8022K/8455K, paused 10ms
05-10 10:47:00.320 834-862/com.maritimconnect.orange.essaiswikitudelunette E/libEGL: called unimplemented OpenGL ES API
05-10 10:47:00.320 834-862/com.maritimconnect.orange.essaiswikitudelunette E/libEGL: called unimplemented OpenGL ES API
05-10 10:47:00.328 834-862/com.maritimconnect.orange.essaiswikitudelunette I/DEBUG: JSON:{"3dmode":"2d"}
05-10 10:47:00.351 834-836/com.maritimconnect.orange.essaiswikitudelunette D/dalvikvm: GC_CONCURRENT freed 2K, 6% free 8026K/8455K, paused 4ms+2ms
05-10 10:47:00.375 834-834/com.maritimconnect.orange.essaiswikitudelunette D/dalvikvm: GC_FOR_ALLOC freed 0K, 6% free 8026K/8455K, paused 15ms
05-10 10:47:00.375 834-834/com.maritimconnect.orange.essaiswikitudelunette I/dalvikvm-heap: Grow heap (frag case) to 8.350MB for 460816-byte allocation
05-10 10:47:00.390 834-879/com.maritimconnect.orange.essaiswikitudelunette D/dalvikvm: GC_FOR_ALLOC freed 0K, 6% free 8476K/8967K, paused 10ms

 

 

And in my activity_main preview, there is this rendering problem :





java.lang.NullPointerException
    at com.wikitude.architect.ArchitectView.e(Unknown Source)
    at com.wikitude.architect.ArchitectView.a(Unknown Source)
    at com.wikitude.architect.ArchitectView.<init>(Unknown Source)
    at com.wikitude.architect.ArchitectView.<init>(Unknown Source)

 

I have seen many threads, but I can't solve this problem ...

 

Thank you for your help !
Login or Signup to post a comment