Start a new topic

Setup guide Intel XDK

Setup guide Intel XDK

Good evening,

Me and my colleague are developing a mobile app to android devices using the geolocation. At this time, we are following the setup guide to the Intel XDK but we have many doubts in the development process. We didn't understand where it is supposed to change the code in the 3º step, because we followed the previous step, so we we're getting the files online. Our main doubt is: if we're getting the online files, how can we change things in the code? And, since the files are too heavy to include in the app's files, we thought it wouldn't be a good ideia download the files to include them.

Can you help us, please?

Hi Rita,
The snippet reference by step 3 can be somewhere in your application js code. It's totally up to you when and where you want to load our plugin and show the augmented reality view.
Step 2 only installs our plugin and yes, the files are on GitHub and will be copied to your project. The GitHub repository only contains our plugin for Cordova. You don't need to edit our plugin. You use our plugin in your application code and change your own source code, not our plugin. You need to add our plugin files to your project, otherwise it can never work. Don't worry about your application size in the end, it will be just fine ;)

Best regards




Thank you for your help.


Well, I'm using Intel XDK, and I did as you told me, but when I do the 'build', I've got this error:

Error: A build-extras.gradle file was detected. Gradle scripts are currently not supported.

Error: A build error occurred. Check the build log.


It only happens following the documentation available in the Setup Guide.

I've been trying to know more about this and I found someone who had the same mistake and asked about it in Intel XDK, but he has no answer, yet.

Can you help me, please?



The Intel XDK does not support Android Gradle builds. Gradle is required by us because we already deliver our SDK as .aar file. That's why we do not support the Intel XDK anymore (announcement will follow soon).

You can try to use an older version of our PhoneGap plugin which still uses .jar files (available on GitHub (version 4 might work)).

Best regards

Login or Signup to post a comment