Start a new topic

Wikitude Sample doesn't work

Wikitude Sample doesn't work

Hello Adrian.

Thank you very much for posting your solution here! The Wikitude community surely appreciates it!

 


1 person likes this
Had the same problem for an old project compiling for a unique device (android 4.4.2) with android-studio :

- Make sure you have wikitudesdk.jar in <your-project-folder>/app/libs/ folder
- Make a copy of wikitudesdk.jar somewhere on your desktop and rename it to wikitudesdk.zip
- Extract it, then rename the `libs` folder to `lib`
- Move the new `lib` folder to <your-project-folder>/app/libs/ folder
- Zip the `lib` folder
- Rename the zip to armeabi.jar
- Add the line compile fileTree(include: ['*.jar'], dir: 'libs') into dependencies{} in your build.gradle from your module
- Clean your project then Build>Build project
- Go to <your-project-folder>/app/build/outputs/apk/
- Open the generated .apk ('app-debug.apk' in my case) with a zip-extractor (e.g 7zip)
- Navigate to /lib folder and make sure 'libarchitect.so' file is present in the architecture folders (e.g /lib/armeabi-v7a/,  /lib/armeabi/  or /lib/x86/)
- Then, in Android Studio, add this code System.load("data/data/<you-package-name>/lib/libarchitect.so");  * before loading/inflating your ArchitectView (in my case, I'm using a fragment to take care of all the Wikitude stuff, so I put this code in a overridden 'onCreate' method)

* you can make sure this is the right path by debuging the app on a device, and launching those adb commands from your console :
> adb shell
> run-as fr.icom.pavillonindustrie
> cd /data/data/fr.icom.pavillonindustrie/
> ls
and see if
libarchitect.so is there

That's it.
Hope it helps people dealing with old projects like me ;)




 


Do you have any updates regarding the port of the epson sdk to android studio?

We can't get the sdk working on the Epson BT-200. We followed all the steps and we were able to launch the app and the menu pops up.

But if you select an example like image on target the camera doesn't start and we can't find a proper solution.

 

Cheers

Hi Adrian,
We're currently working on an Epson update that should go public within the next weeks. Please subscribe to our newsletter so that you don't miss the official announcement.

Best regards

Andreas

Hi!

I am currently trying to implement the SDK sample for Epson BT2000. I have the same issue as Vittorio. When I try to load the AR world is crashes with the same message.

I am using Android Studio for this sample.

Could you please assist?

Best regards,

Adrian

Thank you very much, there is no more issues about libarchitect.so !

Lucille Saadé.

You could try the Wikitude JS API SDK for Android.

 

These are the steps from our Android developer who found out something more:

 Rename the wikitudesdk.jar to wikitudesdk.zip? Extract it but keep the original wikitudesdk.jar in the android libs folder? Rename the `libs` folder to `lib`? move the new `lib` folder to the android `libs` folder

* zip the `lib` folder

* rename the zip to armeabi.jar

* add the line ?compile fileTree(dir: 'libs', include: '*.jar?)? into dependencies{} in your build.gradle from your module

* set classpath ?com.android.tools.build:gradle:1.5.0? to ?com.android.tools.build:gradle:1.3.0? in build.gradle from your project

* make sure the compileSdkVersion, targetSdkVersion  and com.android.support-v4 are 22 or lower

 

Note the changes to gradle and compileSDKVersion

 


Best regards

Andreas

There is no SDK 5.1.2 for vuzix, I can try the wikitude native sdk but does it work on vuzix ?

thanks,

Lucille Saadé

Hi Lucille,
You could try to use our SDK 5.1.2 .aar instead of the 4.x .jar. 

Best regards

Andreas

Hi Licille,
I guess you also wrote in a different thread about this issue. Can you please stick to this one, otherwise it's hard to kepp an overview about what is going on in the Forum and where we answerd what. thx!

Honestly I'm running out of ideas. The steps mentioned before worked for us internally. I will forward your request internally, maybe we find another solution.

Best regards

Andreas

Hi,

I tried both method and none of them work on my project.

Can I have forgotten something to do ?

I created a new project, followed vuzix instruction to set up android application, added wikitude.jar file.

I haven't done "uncheck force error when External jar contains native libraries", because It was for eclipse and I didn't find it on android Studio. Could it be the problem ?

Thank you for paying attention to my problem,

Lucille

Hi,
We used the same steps internally once we started converting the projects, so the steps mentioned above should work.

You can try to create a new .jar file which contains only the `lib` folder with our shared library. You then simply add this new .jar to your android studio project besides our original SDK.

We will release an update to our Epson SDK soon. This update then includes new Android Studio projects.

Best regards

Andreas

Thank you for your answer, but it doesn't solve the problem for me :/. I use android studio.

I have the same error but I am with vuzix smart glasses and not epson, I don't know if it can change something.

Best regards,

Lucille

Hi,
I assume that both of you use Android Studio?
Can you try the followign:

* Rename the wikitudesdk.jar to wikitudesdk.zip
* Extract it
* Rename the `libs` folder to `lib`
* zip it again
* Rename it from wikitudesdk.zip to wikitudesdk.jar and try it again

 

FYI: we will release an update for our Epson SDK in the next month.

Best regards

Andreas

Hi,

Did you find some solutions ?

Unfortunately, I have the same error.

Thanks.
Login or Signup to post a comment