Start a new topic

Camera only show TRIALS word and no camera view

Camera only show TRIALS word and no camera view

4 people have this problem


There is something strange in your configuration, the standard sample application should not show the "unlicensed" watermark.

My suggestion is: try to download the sample application again from github (in a different directory), maybe you are missing some files.

Hi,

Yes, it's happening on all my devices, iOS and Android alike.

Yes, I am using the example files for Phonegap plugin, specifically the Camera Capture with Browsing POIs

Here is the full source of the phonegap WWW folder
https://dl.dropboxusercontent.com/u/7374845/Wikitude_WWW.zip

Thanks a lot man.

Hi, does that happen with all your test devices? Is it our plugin sample application? Which sample are you trying?

If this happens with your code, can you send us some example HTML?

Hi, the patch fixed the camera issue for android device. However, currently, there is a problem that is in both OS, which is the POI, the Radar is not showing.
I did debug the process and found that it said in the ImageResource onLoaded event, that the image is loaded. But it's not showing up in the interface.

There are a few elements that is using AR.ImageResource, all those that use this class will not be shown in the interface. But the POI is there. because I did an alert when it's clicked, and it can respond to click.

Any help would be greatly appreciated!

Thanks. Will be downloading the phonegap version and will test on all of my devices. Will let you guys know if I run into any problem again.

Thanks again.

The new version has passed internal test and is now available for download.

Good news about the coming fix.

The wikitudesdk.jar file from 4.0.1 gave me build errors, however, I had a local version of 4.0.0, and using that I was able to successfully build the phonegap samples to my device - with a working camera.

Thanks for looking at this.

An updated version of the phonegap plugin will be online soon.

In the meantime, you can solve the problem by downloading the official Android SDK 4.0.1 and replacing the wikitudesdk.jar file inside the plugin directory with the file inside the official SDK package.

Hi guys,

We are looking into this issue currently, but we don't have any ETAs yet. We will let you know once this is investigated.

Best,

Martin

I am also facing exactly the same issue.

And have a deadline to meet.  Expect the development team @ Wikitude to please provide a patch asap.

Device and problem are as listed:

Device : Samsung Galaxy S2

Android Version: 4.1.2

Problem : the camera only shows trials word and no camera view however the html is loaded in the background.

 

Device : Samsung Galaxy S4

Android Version: 4.4.2

Problem : the camera only shows trials word and no camera view however the html is loaded in the background.  The POI's are created and there is no error however they are not displayed on the screen.

 

Its the same app behaving differently on the two versions.

Hope we have a solution quickly.

 

Thanks.

Me too, so now I resorted to using the native build for both Android and iOS.
And those examples are working as expected, only phonegap version is giving me critical problems where I can't find even a slight hint of what went wrong with my setup.

If you are like me, working against a tight deadline, I suggest you too, use the native version and not phonegap version.

Hello, I am seeing this exact same issue running the Phonegap samples on Android. I have seen a couple of other posts about it as well.

I am building to a Nexus 4, using Phonegap/Cordova 3.5.0-0.20.9. I also tried the Xcode project to build to an iPad and things are working as expected. I get the same blank camera on Android doing a completely fresh project and plugin install.

I have also been developing a project using an mix of some of the older sample directories and my own code - this project has been working fine, and I have not been able to pinpoint a difference in Android configuration files. Not sure where else to look.

 

 

Actually, on all my devices, I can't take the screenshot. It didn't prompt me for Camera Roll access.
Is there anyway that I can send you my current phonegap files that you can verify for me? 

Because, I am really hitting a dead end here if the example files are not working out of the box.

Here is my phonegap files. https://dl.dropboxusercontent.com/u/7374845/Another.zip

Thanks!

Regarding the screen shot issue. I tried it on a iPhone 4 and it was working as expected. You have to accept the Camera Roll access so that we can save the screen shot.
Does the error callback is called?

On which device are you experiencing the screen shot issues?

Best regards

Andreas

My iOS Device,

iPhone 4 - OS 7.1.2
iPad Mini - OS 7.1.2

Samsung Galaxy Tab 4 7.0 - OS 4.4.2
XiaoMi 3 - OS 4.4.2

Thanks.
Login or Signup to post a comment