Start a new topic

AR application not showing POI on Galaxy S4

AR application not showing POI on Galaxy S4


I have developed small application with Wikitude + Phonegap plugins (WikitudeSDK_Android_3.0.1_2013-07-25_13-13-42). The application is suppose to run on Mobile and on request should fetch data using my own webserive and plot POI on ARWold Browser.

we have tested application on Galaxy S2 before and running fine and showing POIs and also we can click on POIs shows more detail with dialg as implemented but

when we running same application on following Phone

galaxy S4 full size, OS version 4.4.2 and resolution is 1080 x 1920 pixels, 5.0 inches (~441 ppi pixel density)

it is launching application and we confirmed fetching data from our Webservice also but not showing POIs

and sometimes when we increase size of pointer images shows on some other mobile of same make shows markers, but if we keep normal size as working on Galaxy S2 nothing happening even user click on right POI.

Can you suggest or any help on this issue.



We need some support on porting application to work on Galaxy S4

how you can help us can we write you query on any email address for faster reply? because our application doesnt show POI on browser


The Link of SDK you sent us gives us iOS version of plugins. As we are targetting Galaxy S4 we need link of Android version can you give us link please?

I'm sorry, I sent you the iOS link. Here the Android Link

(fyi: updated SDK links of previous posts in this thread)

Hello Rakesh,
sorry for the delayed answer. The Wikitude SDK verision you are using is quite old and doesn't work with Android OS 4.4.2. We had to make adaptations to make it work since there were changes of the Android's webview. Here I send you a link to a newer version where the Android OS 4.4.2 is supported: Wikitude SDK 3.3.2 for iOS/Android

Hope that helps,

We are working on POC  to showcase and apply for commercial license of WikitudeSDK

so your help is needed to solve this issue and most of the Managment peolpe using Galaxy S4


We prefer to communicate via forum post. In case of code-snippets that are sensitive you can send them to and refer to this forum post.

In fact you shouldn't need to port any code. It should be enough if you replace your wikitudesdk.jar file which you can find in your phonegap project with the wikitudesdk.jar file of the Wikitude SDK 3.3.2 for Android

Let me know if it worked for you,

Hi Christian,

We tried what you suggested in your earlier post.

Downloaded the Wikitude SDK 3.3.2 and replaced the wikitudesdk.jar

But still the same problem exists.

There is another thread where we have been discussing this issue and necessary files have been uploaded.

Could you please have a look at the files and suggest what is going wrong?


One observation that I would like you to really look upon.

AR.context.onLocationChanged = MyWorld.locationChanged;

This event which should get triggered on location change doesnot not get triggered on Samsung Galaxy S4 with Android 4.2.2

Any help would be appreciable.




If the AR.context.onLocationChanged is not being called then you don't receive a location. To check that go outside in order to get a gps signal. If that doesn't help, install a location spoofer app in order to check if this is the problem or execute your function by calling it in your code with a fake location to test it. You could also add an alert to your onLocationChanged function with the lat/lng and check if they are correct. We do not have any influence on the location trigger since we have to rely on the sensors of the device and the OS itself.

I cannot reproduce the issue. I suggest you have a look at our examples app as a starting point since this is tested and we know that this works. Therefore use the latest Wikitude SDK 4.0.1 for Android, get the latest wikitude phonegap plugin and follow the instructions of the installation documentation.

I gave you the link to our latest SDK 3.3.2 because I thought you purchased a licence for the SDK 3.0.1 so your licence would still be valid. In general I recommend working with the latest SDK which currently is version 4.0


We have created new application with latest vesion on SDK

and that is working fine on Galaxy S2 but not on S4

that is the question same application working on S2 and not on S4.



Does the location trigger fire? I mean is the function you assigned to AR.context.onLocationChanged being called on the Galaxy S4?



Yes, location trigger gets fired on S2 and shows us lat/lon in the alert message but not on S4. What can be the issue. why this is acting diferent on the S4?

Any suggestions.




Hi Rakesh,

I guess this is a device issue. I did a little research and found out that there are quite some people out there who have GPS problems on Galaxy S4. Most of them report the issue was resolved after uninstalling certain apps that use GPS. Here a link to one post I found: GPS issues on Samsung Galaxy S4.

Since this is a device issue I can't really help you. For your AR experience I suggest to display a warning to the user if no location was received after a certain timeout to inform about location issues.

Hope that helps,
Login or Signup to post a comment