Start a new topic

AR link

AR link

I have a Samsung Galaxy s2, running gingerbread with wikitude 7.5 installed.  when I try to link to a world from my browser I get the page tht says "oops, you need to install wikitude on the device" etc.


Please assist?

I have the same problem.
Hi Ralf,

May I ask on which device(s) are you experiencing this issue?

It would be truly helpful to know the model, operating system and its exact version (e.g. Android 2.2.3), and the version of Wikitude World Browser installed on your device.

We'll assist you as soon as possible.

Thanks for your interest in ARLink!

Kind Regards,

Hi Simone,


thank you.

My device: Galaxy SII - Android 2.3.3 - GINGERBR.XWKF3

WikiTude 7.5.1





Hi Ralf,

Unfortunately the first round of tests didn't show us the issue. I have to ask again your collaboration through several questions:

1. Are you using the embedded browser of your device, or other third parties browser like Opera, Chrome, Firefox.. ?

2. May I ask your User Agent displayed through the browser ? It might help to visit a website like

3. Which URL(s) are you trying for ARLink ?

4. Has your Wikitude version been upgraded from a previuos one, or,  has it been installed from scratch ?

Thanks for your support and let me apologize for all those questions.

Kind Regards,






Hi Simone,


I use the embeded browser. (I open a website in the device browser. There I try to redirect to the ARLink via window.location = "")

I installed the latest version of wikitude - no update. (I have also installed the WikiTude ARchitect viewer)

The URL I try is:



Regards Ralf

Hi Ralf,

Finally, we were able to reproduce the problem. 

Thanks to your support we discovered that the issue is depending from a limitation of the operating system: in fact, calling the URL through window.location (or similar ways) doesn't allow to Wikitude to start properly.

I've forwarded the ticket to our clients department which are already working on it.

Currently, the best workaround (for Android) is to embedd the ARLink URL in a explicit way, e.g. with <a href="you_ar_link"> Click here </a> .

The issue is affecting some version of Android. Instead, iOS or BlackBerry versions are not affected.

Stay tuned!


Hi Simone,

thank you. The workaround works fine.

By the way. Is it possible to get rid of the phone-id permissions of the app? This seems to be a big problem in the community.





Hi Simone,

I have the same problem with samsung galaxy s2.
I tried to solve the problem with a link:

<p><a href="">Link</a></p>

but i still don't keeps saying "Oops, You need Wikitude installed on your device to complete this action. Download it now to fully immerse yourself into the world of Augmented Reality." What am i doing wrong?

(I'm using Chrome as browser and have version 7.7 of Wikitude)

Any update on when this issue will be solved?

I am trying to embed the link into a mobile app, but only get to the page that says Wikitude is not installed... (which it is!)

Hi Ted,

Thanks for your finding.  It should be related to the Chrome Browser. I'll forward the ticket internally so that we can perform all the checks.

Have a nice day,


Hi Benny,

Which approach are you using between the one described above ?



Hi Simone,

I am trying to integrate the link into a mobile app created with

I tried with direct link, and also with an HTML page with <a href...

but I cannot control which browser the app opens. It always opens the users chosen default browser.

on my test device it opens Opera Mobile browser, and that does not recognize that wikitude is installed.

I would like to link directly to the wikitude app, without opening a browser first.

Another example where I use something similar, is when I link to KML files that are opened directly in Google Maps app. Basically I need the same functionality as with maps... just for Wikitude.

PS! When copying the link from the "Basic" page of a world, there is a missing "/" slash in front of the "?" question mark!
Login or Signup to post a comment