Start a new topic

Unity: Client Recognition - Simple not working with own .wtc

Unity: Client Recognition - Simple not working with own .wtc


I was testing the Wikitude Unity Plugin in Unity (5.3.4 with Nexus 4). I noticed that the example "Client Recognition - Simple" worked with the collection the first time, but as soon as I tried it with an own collection, the 3D object just didn't show up.

- I added my own .wtc to the Streaming Assets folder (contains 1 target)

- I selected this Target Collection in the ClientTracker

- The TargetPattern in the Trackable game object is "*"

- When I build it on my Nexus 4, the WikitudeEye does not appear.


Side note: In the example scene is selected by default, but when running the scene, it only shows the 3D object when the magazine pages are visible. Is this behavior intended?

Thanks for any help!

Ok, I just noticed that this file has 0kb on my device: Androiddata\files\

So the file is not streaming successfully from the StreamingAssets folder. Weird...


If your wtc file is 0kb then this should be causing the issue. Could you please refer to the documentation here about wtc files? 

The source .wtc-file is correct and it has 33kb on my local drive. There seemed to be some error with streaming the asset to my mobile phone I guess.

I was now able to fix the issue by moving the wtc file from the StreamingAssets/Wikitude folder to the StreamingAssets root folder. Now the .wtc file on my phone streams correctly and has 33kb. Also the 3D object appears now.

This worked for me as well. First i got it to work then suddenly nothing worked. I did as you did and moved from streamingassets->wikitude to root folder streamingassets and now everything works. Thanks
Login or Signup to post a comment