Start a new topic

Wikitude 3D encoder crash when open 3D model

Wikitude 3D encoder crash when open 3D model

I have installed the latest Wikitude 3D Encoder (1.2.1) on my Windows 7 (32bit) machine. But when I tried to open 3D model files (either .wt3 or .fbx), it crashed. I got this as message:

  An unhandled win32 exception occured in Wikitude3dEncoder.exe .

  Problem Event Name:    APPCRASH
  Application Name:    Wikitude3dEncoder.exe
  Application Version:
  Application Timestamp:    565d0f96
  Fault Module Name:    StackHash_0a9e
  Fault Module Version:
  Fault Module Timestamp:    00000000
  Exception Code:    c0000005
  Exception Offset:    00000000
  OS Version:    6.1.7600.
  Locale ID:    1057
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789


Any solutions?

So the 3dEcnoder starts and shows the grid? That is, the basic rendering in the viewport works?

And if you open any fbx file the app crashes? Is there any fbx file which does not crash?

Which graphics card (vendor, model) does your PC contain?

Is your graphics card driver up-to-date?

Yes, it shows the grid when starts. It crashes when I try to open or import fbx or wt3 files.
I have tried to open any fbx files I have, and even car.wt3 from the sample. But unfortunately none of them can be opened.
I'm using Intel G41 Express Chipset, and the driver is up-to-date.

Is there any old version of Wikitude 3D encoder available?



I have downloaded the latest version (1.3.1), but the same error still happens. sometimes with the additional error gameplay-encoder.exe has stopped working

Please try to install the graphics driver downloaded directly from the vendor of your integrated GPU:
Some users report that the Windows driver for this chipset does not support OpenGL and that Microsoft's driver replaces the Intel driver during the Windows updates.

This, however, does not explain that the gameplay-encoder.exe does not finish processing since it doesn't use OpenGL. So there may be another problem. You can try to open a Windows Command Prompt, navigate to <Wikitude3dEncoder-Install-Dir>tools\windows\ and import an fbx file manually via 
gameplay-encoder my.fbx -o my.gpb
This should provide some shell output and may hint to the source of the problem.

If the error occurs only with certain fbx files you can also send us the file so that we can have a look at it.

Thank you for your reply. I will try what you suggest, and maybe I will try to install the application on another machine too. Hopefully it will work somehow.

I have installed Wikitude 3D encoder on another machine, and it worked great.

I guess I have to upgrade my PC

Once again, thank you for your replies.
Login or Signup to post a comment