Start a new topic

Architect View will not start - Missing linker flag.

Architect View will not start - Missing linker flag.

Hi Folks,

I'm having a bit of a strange problem that I can't seem to get my head around.

I have an empty xcode project that I've just added Wikitude to, following the setup guides as descibed in the docs. Every time I try to call the WTArchitectView start:completion: method, it fails and moans that ObjC linker flag isn't present, as per the below:

Printing description of error:


Error Domain=com.wikitude.architect.PublicAPIUsage Code=994 "Missing Linker Flag '-ObjC'" UserInfo={NSLocalizedDescription=Missing Linker Flag '-ObjC'}

The project does however have "-ObjC" in the Other Links Flags for both the project itself and the current target. Screenshot of linker settings below.

Build environment is:

Xcode 7.2 (7C68)

iOS 9.2 as deployment target

Wikitude SDK 5.1.1 (also tried with 5.0.0 and 5.1.0)

Am I missing something?

Thanks in Advance,


hi, did you solved it? i have the same issue.


Have you checked the 'isRunning' argument that is given to the completion handler?

The error message appears for me as well but isRunning is YES and the SDK works fine. I need to investigate why the error message is set although everything is fine in the background.

Best regards


Hey Guys

The project actually builds and runs fine and the Architect View does present both the camera and any content that I try to load - just wondered if the message was anything that I needed to worry about. Initially I suspected CocoaPods because I have a few flags overridden to get it to play nicely. 



Hi Chris,
There was a bug in our SDK which always set the error pointer but the BOOL was always set correctly. It will be fixed in 5.1.3 which is available within the next days.

Thx for pointing that out!

Best regards

Login or Signup to post a comment