Start a new topic

Image : Format (Unknown) not supported

Image : Format (Unknown) not supported

Hi guys,


We're facing a very strange problem :


We've got some images which don't display on WikitudeView (They are attached to this message).


The problem occurs with Wikitude 4.0.2 on iOS and Wikitude 5.0 on Android.

With Wikitude 4.0.2 we've got an error message : Wikitude SDK: Image (12): Format (Unkown) not supported. (The number changes, 12 / 14 / 16 / ...).

We haven't got any message with Wikitude 5.0.


These images are Jpeg or Png.


We can display these image in a iOS UIImage, jpegtran processes the image (jpg ;)) correctly, image magic tools (identify) detects the images as valid image files.


How can we get more information about the error ?

We've tried to implement the onError callback from AR.ImageDrawable but we didn't get any valuable information.


Thanks for your help :^)

Hi Mathieu!

Please try scaling the images down to maximum 500px in dimension and let me know if this solves the issue.

Best regards,

I've got the same result with smaller image.

These images are generated with PHP GD2.

The originals are displayed in the view but not the scalled images.

It's why we tried them on many tools (UIImage from iOS, image magic tools and jpegtran) and they seem to be OK.

Are there any mandatory header ?

I attach the smaller picture

We've narrowed down the problem, redirection (301) is issued when the image is requested.

Is there any way to follow the redirection ?

please test on Android and iOS.
In case your setup works on one platform but fails on the other please send us further details via eMail to forum (at) wikitude (dot) com, referring to this forum post.
If it fails on both please check your server config or update the urls so they directly point to the file.

Best regards
Login or Signup to post a comment