Start a new topic

"Protocol not supported" Error when trying to use recorded .wtm file

"Protocol not supported" Error when trying to use recorded .wtm file


on the new Samples app for iOS we are able to test the new 3D-Tracking, by recording and using a tracking map. But recording a tracking map and using it for ur own app is possible too.

There could be an issue with the Map-Tracking-Recorder in the samples app. When recording is finished, I download the created .wtm file through iTunes-Filesharing and copy it in my resource bundle for my own app. After running the app and calling


from WTWikitudeNativeSDK.trackerManager, I get an error from the delegate method

clientTracker:(WTClientTracker *)clientTracker didFailToLoadTargetCollectionFromURL:(NSURL *)URL withError:(NSError *)error;


Message: "Protocol not supported ('path to .wtm file on device')".

Which protocol is meant with this message? The iOS protocol/delegate or the file's protocol? Does anyone else have this problem? 


Thanks in advice.

Hi Dennis,
Could it be that you specified 'path to .wtm file on device' as client tracker URL?

Protocol not supported ('') contains the protocol from the client tracker URL, so I guess you didn't passed a valid URL when creating the ClienTracker object.

Best regards



thanks for the quick response. It solved my problem. My attempt was . So the missing part in that NSURL-Object was "file://" in front of my string. I switched it to NSURL.initFileURLWithPath: and in works now.

Thank you.
Login or Signup to post a comment