Start a new topic

ADE error with first example

ADE error with first example

Hi devs,

I've tried out the first example and got stuck with the ADE tool when I wanted to test it locally on the webbrowser. I got the following error message, also shown at the screenshot:

Uncaught TypeError: AR.ClientTracker is not a function

I didn't find anything related to that error and wanted to know what it is and how I could debug locally?
I found this thread and I'm not sure if it's related to my issue?

In the Wikitude App itself the world is working fine.



Please send me your complete AR experience (including the html, js, assets, target images, etc.)  to forum



Hi Nicola,

I encounter the exact same problem with all the samples included in "wikitude-sdk-samples-master"
Do you have a solution for me  ?



We have this on our list to fix. In the meantime please have a look here which explains on device debugging using the webinspector. This is applicable for iOS. If you need to test on Anroid you can as well work with a webinspector.

I hope this helps. Greetings



Is this error solved as i am able to run the sample successfully and see the car model but i am not able to render my wt3 file created by wikitude encoder.

I am not getting any error but not able to see the model.


Please send the .fbx file and the .wt3 file over so we can check (you can send it to forum

Thx and greetings


I have attached my .fbx and .wt3 files.


You can't see the model, because it's too far 'up' from the origin. If you open the 3DEncoder -> the center of the grid you see matches the target image. So in your case, if you zoom out in the Encoder you'll see your arrow very far away from the 'grid' and therefor from the target image. So please position your arrow that it's visible on the grid without the need of zooming out.

If you model is too big in dimensions, then you can also shrink it.




Thank You So much now i am able to see my 3d model but i can see that only on car.png and its wtc file.

When i try to do insert my wtc file its shows:

11-20 10:22:44.589  13121-13195/com.wikitude.sdksamples E/SQLiteLog? (14) cannot open file at line 32473 of

11-20 10:22:44.589  13121-13195/com.wikitude.sdksamples E/SQLiteLog? (14) os_unix.c:32473: (2) open(/NotificationPermissions.db) -

11-20 10:22:44.589  13121-13195/com.wikitude.sdksamples D/WebKit? ERROR:

11-20 10:22:44.589  13121-13195/com.wikitude.sdksamples D/WebKit? SQLite database failed to load from /NotificationPermissions.db

    Cause - unable to open database file

11-20 10:22:44.589  13121-13195/com.wikitude.sdksamples D/WebKit?

    external/webkit/Source/WebCore/platform/sql/SQLiteDatabase.cpp(71) : bool WebCore::SQLiteDatabase::open(const WTF::String&, bool)



Please guide  me and i am attaching my png file and the respective wtc file.



Your target image is too small. You can find guidelines on good target images here.

Pleaes check these steps from the documentation section on how to work with your own target images and the sample app:

Recognize your own images

Upload your images to the target management tool (log-in required)

Generate your target collection file (.wtc)

In your code create an AR.ClientTracker and load the target collection file from the previous step

Create an AR.Trackable2DObject and assign your targetName

Make sure that the targetName used with the AR.Trackable2DObject correspond to one of the target names in your target collection. You can also use a wildcard to match any target or only a specific subset of targets. Please refer to the AR.Trackable2DObject main documentation for more information about wildcards.
Login or Signup to post a comment