Start a new topic

iOS POI base AR does not work on iOS 8.3

iOS POI base AR does not work on iOS 8.3

Sounds great! Thank you Roman!

Yes it works now without any change in code. Thank you Roman.

Lukasz, does it work with the suggested changes?

Yes, the different iPhone is on iOS 8.3, mine on 8.2. But: I have just now fixed it on my iOS 8.2 device as well. Here is what I did:

iPhone Settings > General > Reset > Reset Location & Privacy

I would be very interested to know, if this reset works for you as well.


Roman, thank's for sharing your experiences with this issue. One suggestions: you could install an app which displays the sensor values and check values of the accelerometer, the gyroscope and the compass. Maybe the compass is not really the problem on your iPhone6 but a different sensor.


That diffrent iPhone 6 has the same iOS ?

For displaying POIs you need to start the architect view (solely or additionally) with the Geo extension:


And don't forget to check if the device supports the features before allocating the WTArchitectView:

if ( )

Initializing the the WTArchitectView with the motion manager with nil is ok:

I advise you to remove the project from GitHub or at least the SDK-key. Not that somenoe else uses it.

Hope that helps,

Interestingly enough, I tried on a different iPhone 6, and both, the Samples App and the Test from Lukasz work just fine!

Somehow my iPhone 6 has a compass problem. Though the compass works fine in the compass app and in other apps, it seems to always point North with my Wikitude tests. Very strange, I will try to reset/update this bad iPhone next.




I seem to have the same problem. I built the "Plugin Samples" app and used:


iPhone 6 - Firmware 8.2

Cordova 3.8.0 (via npm and phonegap)

Wikitude Plugin with release date 09.03.15


I tried the 4.3 and 6.2 examples (and others) in the Samples App. Regardless of how I move the phone (outside) or tilt or pan, the POIs always stay frozen.


I also just tried the Test App from Lukasz, and also there, the POIs stay frozen for me. Even after adding your suggested changes.





Any updates?

For this issue I have seprated project. You can see full code here

This is because the onLocationChanged-trigger fires only when the latitude, longitude, or altitude changes. You do not yet have access to the position of the device in the 3D space via our API, such as accelerometer or gyroscope values.

I do not have any diffrent devices. I did some more tests, on compass/accelometer change onlocationchange is not executed, only on location change.

I'll try to reproduce the issue. Is is possible for you to test the example on a different iOS device in the meantime?

Correct, on location change I see the change in poi position, but the pois stays in the same position on device rotate or gyro change. The compass works good on maps or any other app.

Edit: If the value from the compass is invalid still there should be a change in poi position on iPhone screen.
Login or Signup to post a comment