Start a new topic

3D lighting and material

3D lighting and material


please, what is currently the recommended way to export a model from Blender to Wikitude 3D Encoder?

I'm trying to add ambient light to my scene. Ambient light setting from Blender is ignored. I tried both DAE and FBX export.

When I try point light, I'm unable to import the DAE model. After removing attenuation parameters, DAE model is imported, but light is a point light and not ambient light.

Best regards,


Add a point light and a directional light (sun). Remove the attenuation parameters from the point light in the exported DAE file (constant_attenuation, linear_attenuation, quadratic_attenuation) but leave the color tag. The point light will be displayed as ambient light.

Hope that helps,


Hi there,

I'm also having some dificulties in setting the lights in a Blender model and export it in FBX for wikitude 3d model encoder.

The only way my model lit perfectly in the encoder is when I set a single sun as light source, and nothing else. In this case, my model looks nice, but the other side is too dark (black).
Setting higher intesity for the sun in Blender, moving closer-farer does not make any change in the encoder.
I would love to add an ambient light but adding a point light after my sun is added will make it black-and white in the encoder, and adding only a point light will make it weird looking, like fully tinted to its material color (no shadings, edges, etc.)
However, if I add a point light and after that adding a sun will make it looks nice again (apart from that the other side is still too dark)

Looks like the encoder ignores all lights except the last one added in Blender?
Or am I missing something here?

Thanks in advance!


Can you check the amibient light setting of your model, as discussed here:

Hi Roland,

Thanks for your answer and the link! Yes, my ambient color is set to white, and the World's Environment lightning is also set to white.

I'm sorry if it's a Blender issue, but I'm not sure, as if I render an image within Blender, I can see the object correctly lit around with the ambient light and it changes accordingly if I for example increase the Energy for the Environmental Lighting.
However, if I export it to fbx I still see it halfway dark and it does not seem to react for any changes.

Thanks and kind regards,



You can check the fbx exported from Blender with the Autodesk FBX Reviewer. If you turn on lighting in the FBX Reviewer and the model appears black, this indicates that the ambient light color in the fbx is black. 

If the ambient light has an effect in the FBX Reviewer you can send us the file and we take a look at values imported in the Wikitude3dEncoder.

Great idea, thanks!

I have checked it in Autodesk Preview and it looked perfect! No dark half on the unlit side.
I would be very happy if you could take a look at my file. :)
I will post it tomorrow when I arrive in the office.

Thank you and have a nice evening,



I need to correct myself, as I see in Autodesk Preview, the bottom (unlit) part of the object is not black, but solid, tinted material color, while the top, the lit side is perfect.
In the encoder, the bottom part is dark/black and the top is OK. For some reason, the whole object is way darker in the encoder than in the Autodesk Preview.

Thank you in advance for taking a look at my files:

Blend file:


Kind regards,


Thx for the files. The settings in Blender seem to be ok. However, the fbx file still shows ambient light black. So it's the Blender exporter who is causing this.

I will try to find a workaround for that within the next days.

Awesome, thank you! Highly appreciated! :)

(I told my boss, that your support is excellent, so I'm pushing him to buy a license ;) )

Can you try the following: 

1. add a point light to the scene
2. set the color of that light to your preferred ambient light value
3. set it to invisible (i.e. disable the eye icon) in the scene graph view

Export the model to fbx and convert it with the encoder.

I had some problems loading of the wt3, but maybe it works with your version of the SDK. That is, no guarantee that it works.

A fix for the import problems is ready and will be available with the next release of the SDK.

Hey Roland,

Thanks a lot for the new workaround!
Unfortunately it didnt change anything, my object is still half-way dark/tinted no matter how I export it, with or without other light sources, hidden from viewport, hidden from rendering, the result is always the same. :(

I think that all of my lighting problems would immediately disappear if there was a chance to use more than just one light source. (i.e. placing a directional above and below)

Is there any planned date for the release of the SDK version that contains the fixed import methods?

Thank you and kind regards,


Sorry, I forgot one point. Try it with 

1. add a point light to the scene
2. set the color of that light to your preferred ambient light value
3. set Falloff: constant
3. set it to invisible (i.e. disable the eye icon) in the scene graph view

Please try again. 

Regarding the multi-lighting: I fully agree, but it will not be available soon. Sorry. If you need a more sophisticated 3D rendering you may consiter using the Wikitude Unity Plugin.

Dear Roland,

Thank you for the tip! Unfortunately it didn't help me.
I've been playing with the settings for hours now, but still couldn't achieve an evenly lit object in my cordova app.
The best I could make is the one I have linked above, when the lit side is perfect, but the other is dark.
Am I the only one who has problems with this? :)

I cannot switch to Unity as my app is created in Cordova, but I wonder if there was a way to make the export without any lights and add a single light source in the encoder or within javascript.
I wouldn't mind the dark half of the object if it doesn't rotate towards me... :)

Thank you and best regards,



Sorry to come back to you only now. 

I had another look at the ambient light settings for Blender. I tested with the Wikitude3deEncoder 1.4 available via our download page and the settings I described in my previous post, and it works. 

Please make sure to apply the properties of the point light as shown below. The color point light source in Blender is then used as the ambient light of the scene in the Wikitude3dEncoder. 

Login or Signup to post a comment