Start a new topic

3D lighting and material

3D lighting and material


Maybe I found the reason why it didn't work for you: I realize that the order of light sources matters. 

As you hopefully can see, the order used in the blender attachment in my previous posting provides the lighting and ambient light expected in the encoder. 

I adjusted the encoder accordingly. So in the next release of the SDK 5.2 and the encoder 1.6 the order of the light sources will not matter anymore.

Hope that helps.

If I open the fbx attached below with the encoder I see the 3D model without any black faces. You can see the settings in the blender file attached.

Dear Roland,

Thank you very much for your efforts on further helping me out, really appreciate it!
Among others I tried exactly this method, but unfortunately could not achieve any improvement on the lights.

Thank you and best regards,

Marton

Sorry to come back to you only now. 

I had another look at the ambient light settings for Blender. I tested with the Wikitude3deEncoder 1.4 available via our download page and the settings I described in my previous post, and it works. 

Please make sure to apply the properties of the point light as shown below. The color point light source in Blender is then used as the ambient light of the scene in the Wikitude3dEncoder. 

 

Dear Roland,

Thank you for the tip! Unfortunately it didn't help me.
I've been playing with the settings for hours now, but still couldn't achieve an evenly lit object in my cordova app.
The best I could make is the one I have linked above, when the lit side is perfect, but the other is dark.
Am I the only one who has problems with this? :)

I cannot switch to Unity as my app is created in Cordova, but I wonder if there was a way to make the export without any lights and add a single light source in the encoder or within javascript.
I wouldn't mind the dark half of the object if it doesn't rotate towards me... :)

Thank you and best regards,

Marton

 

Sorry, I forgot one point. Try it with 

1. add a point light to the scene
2. set the color of that light to your preferred ambient light value
3. set Falloff: constant
3. set it to invisible (i.e. disable the eye icon) in the scene graph view

Please try again. 

Regarding the multi-lighting: I fully agree, but it will not be available soon. Sorry. If you need a more sophisticated 3D rendering you may consiter using the Wikitude Unity Plugin.

Hey Roland,

Thanks a lot for the new workaround!
Unfortunately it didnt change anything, my object is still half-way dark/tinted no matter how I export it, with or without other light sources, hidden from viewport, hidden from rendering, the result is always the same. :(

I think that all of my lighting problems would immediately disappear if there was a chance to use more than just one light source. (i.e. placing a directional above and below)

Is there any planned date for the release of the SDK version that contains the fixed import methods?

Thank you and kind regards,

Marton

Can you try the following: 

1. add a point light to the scene
2. set the color of that light to your preferred ambient light value
3. set it to invisible (i.e. disable the eye icon) in the scene graph view

Export the model to fbx and convert it with the encoder.

I had some problems loading of the wt3, but maybe it works with your version of the SDK. That is, no guarantee that it works.

A fix for the import problems is ready and will be available with the next release of the SDK.

Awesome, thank you! Highly appreciated! :)

(I told my boss, that your support is excellent, so I'm pushing him to buy a license ;) )

Thx for the files. The settings in Blender seem to be ok. However, the fbx file still shows ambient light black. So it's the Blender exporter who is causing this.

I will try to find a workaround for that within the next days.

Hello,

I need to correct myself, as I see in Autodesk Preview, the bottom (unlit) part of the object is not black, but solid, tinted material color, while the top, the lit side is perfect.
In the encoder, the bottom part is dark/black and the top is OK. For some reason, the whole object is way darker in the encoder than in the Autodesk Preview.

Thank you in advance for taking a look at my files:

Blend file: https://www.dropbox.com/s/6g6opujdgu6tlyq/sziv.blend?dl=0

FBX: https://www.dropbox.com/s/r5zp1cyd0ly0ff2/sziv.fbx?dl=0

Kind regards,

Marton

Great idea, thanks!

I have checked it in Autodesk Preview and it looked perfect! No dark half on the unlit side.
I would be very happy if you could take a look at my file. :)
I will post it tomorrow when I arrive in the office.

Thank you and have a nice evening,

Marton

Ok.

You can check the fbx exported from Blender with the Autodesk FBX Reviewer. If you turn on lighting in the FBX Reviewer and the model appears black, this indicates that the ambient light color in the fbx is black. 

If the ambient light has an effect in the FBX Reviewer you can send us the file and we take a look at values imported in the Wikitude3dEncoder.

Hi Roland,

Thanks for your answer and the link! Yes, my ambient color is set to white, and the World's Environment lightning is also set to white.

I'm sorry if it's a Blender issue, but I'm not sure, as if I render an image within Blender, I can see the object correctly lit around with the ambient light and it changes accordingly if I for example increase the Energy for the Environmental Lighting.
However, if I export it to fbx I still see it halfway dark and it does not seem to react for any changes.

Thanks and kind regards,

Marton

Can you check the amibient light setting of your model, as discussed here: https://support.wikitude.com/support/search/topics?term=Ambient+Light+on+Blender+3D+Models
Login or Signup to post a comment