Start a new topic

Activity automatically closed :'(

Activity automatically closed :'(


Hello,

I have the same problem here, I tested in two devices zte blade and zte v875. I already added all mentionated libs.

Hope you can help,

Cheers.

 

Hi there!

We recently added support for Vuforia 2.0 SDK. As I saw in your log, you are still using version 1.5.9 of the Vuforia SDK. Your issue might be related to that fact. Please try and download Vuforia SDK 2.0 and make sure you use the latest version of the libExtensionVuforia.so provided in the Wikitude SDK package.

Please let me know whether that helps

Best regards

Markus

 

Hi,

 

I've made an activity where I've put a button. When the user hits the button, another activity is shown. This activity is the ArchitectViewActivity. The activity is loading during 2 or 3 seconds but automatically closes and the phone goes back to the parent activity. The video camera view is shown 1 second and the background become black. The architect view  (HUD) is loaded, ressources are loaded and the activity closes.

 

 

 

Do you have any idea what's happen ? I've really spent time on this :'(

 

 

 

Thanks.

Hi,
 

Which device are you using? Did you set-up all permissions as recommended?
Could you please open the "SimpleARBrowser" example project from the Android SDK's  "Android/Examples"-folder and let me know if this works properly?
Please also have a look at the logcat output of your Eclipse console and let us know if there are any Wikitude specific errors in the log.

Thanks for your help.
Cheers,
Andi

Dear Andreas,

>Which device are you using?

It's a Samsung Galaxy SII.

>Did you set-up all permissions as recommended?

Yes I think I do:

 

 <uses-permission android:name="android.permission.INTERNET" />

    <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />

    <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />

    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />

    <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />

    <uses-permission android:name="android.permission.ACCESS_GPS" />

    <uses-permission android:name="android.permission.CAMERA" />

    <uses-permission android:name="android.permission.INTERNET" />

    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />

    <uses-permission android:name="android.permission.READ_PHONE_STATE"/>

 

 

 

> Could you please open the "SimpleARBrowser" example project from the Android SDK's  "Android/Examples"-folder and let me know if this works properly?

 

Yes, it works perfectly :'( I think I've made something wrong from the Andro?d point of view, but I don't know what is the problem. This makes me crazy :'(

 

Regards.

Hi Olivier!

I recommend to place some break-points and have a closer look at exception that may be thrown in your code.
As a fallback: Feel free to e-mail to android (at) wikitude.com and attach some code.

Cheers,
Andi

Hi Andreas,

 

Unfortunately, there is no exception thrown in my code (this would be great...). The app doesn't crash. The app automatically goes back to the first activity as if I've hit the back button.

 

Olivier.

 

Hi again!

Could you pelase check the following:


Open Wikitude App, press "Menu" - "Settings"; Scroll down to developer Settings, enter your World's url and press "open". Is your World displayed properly? If yes: Your device is fine and project setup is the issue

Also ensure you have minSDK/targetSDK set properly in your manifest

<uses-sdk android:targetSdkVersion="15" android:minSdkVersion="8"/>



If you are using Image Recognition in your SDK



Prerequisites:



You need to register as developer at Wikitude and downloaded the SDK, two files from the SDK's Android-folder are required, as described below.



Download the Vuforia Framework from Qualcomm (You need to register yourself as a Qualcomm developer)





SETUP


Import HelloImageRecognition-project in Eclipse as Android-Project


Copy wikitudesdk.jar from the Android WikitudeSDK to project's libs-folder



Copy libExtensionVuforia.so from the Android WikitudeSDK to libs/armeabi-folder (create subfolder if necessary)



From Qualcomm's Vuforia SDK: Copy QCAR.jar to your projects libs-folder and add it to your project's build. Also copy Vuforia's libQCAR.so to your libs/armeabi-folder


 

Hi Andreas,

 

Thanks for your answer.

 

>>>Open Wikitude App, press "Menu" - "Settings"; Scroll down to developer Settings, enter your World's url and press "open". Is your World displayed properly? If yes: Your device is fine and project setup is the issue

 

Yes, the world is displayed properly. This is a project setup issue but I can't fix it :'(

 

 

>>> Also ensure you have minSDK/targetSDK set properly in your manifest

>>> <uses-sdk android:targetSdkVersion="15" android:minSdkVersion="8"/>

 

My app already uses these parameters.

 

>>> If you are using Image Recognition in your SDK

 

Yes, am I.

 

>>> You need to register as developer at Wikitude and downloaded the SDK, two files from the SDK's Android-folder are required, as described below.

Already done.

 

>>> Download the Vuforia Framework from Qualcomm (You need to register yourself as a Qualcomm developer)

Already done.

 

>>> Import HelloImageRecognition-project in Eclipse as Android-Project

>>>Copy wikitudesdk.jar from the Android WikitudeSDK to project's libs-folder

>>>Copy libExtensionVuforia.so from the Android WikitudeSDK to libs/armeabi-folder (create subfolder if necessary)

>>>From Qualcomm's Vuforia SDK: Copy QCAR.jar to your projects libs-folder and add it to your project's build. Also copy Vuforia's libQCAR.so to your libs/armeabi-folder

 

I've done everything. Please look at these few lines:

 


11-12 19:37:21.739: I/AR(19575): QCAR has been initialized successfully

11-12 19:37:21.739: I/AR(19575): QCAR SDK version 1.5.9



11-12 19:37:21.794: I/ArchitectWebView(19575): start loading tracker with url:>http://www.webtv4.fr/Wikitude/SkanTagWikitudeData/DataSet/Demonstration.zip



11-12 19:37:27.469: I/ArchitectWebView(19575): Successfully downloaded file: /mnt/sdcard/com.skantagapp.skantag/Demonstration.zip



11-12 19:37:29.469: D/ArchitectWebView(19575): JS to load: AR.__getObject__(4).onLoaded()



11-12 19:37:32.309: D/CLIPBOARD(19824): Hide Clipboard dialog at Starting input: finished by someone else... !

 

The com.wikitude.architect.ArchitectView is displayed during few seconds but the activity is automatically closed and the app displays the first activity.

 

I really don't know why the activity is closed like that...

 

Olivier.


 

Hi again,

Quite hard to fix the issue remotely. Just in case you're in a hurry and have are not working on a super confidential project:
Feel free to mail me your zipped project (or send me public-dropbox link to the zip file) to
android (at) wikitude.com

Otherwise:


Did you already test on another device? Do you have a custom ROM on your S2

Have you tried another *zip-file for your tracker, e.g. the one in the SimpleIRBrowser project?

Try to adjust the SimpleIRBrowser project step by step, so you ensure a life-cycle calls etc. are set-up properly


Cheers,

Andi

 

Hi Andreas,

 

 

>>> Quite hard to fix the issue remotely.

 

Yes it is.

 

>>> Just in case you're in a hurry and have are not working on a super confidential project: Feel free to mail me your zipped project (or send me public-dropbox link to the zip file) to android (at) wikitude.com

 

I will send you the zip file meanwhile I will try to test your three points.

 

Thanks,

Olivier.
Login or Signup to post a comment