Start a new topic

iOS App Compilation Error

iOS App Compilation Error


Hello I am trying to build the phonegap ios app by following the guide listed here -

https://github.com/Wikitude/phonegap-plugins/tree/master/iOS/AugmentedReality-Wikitude/Plugin

The only extra thing which I aded in my project not listed in above guide is -

In my target settings -> user header search path - added the path to wikitude sdk inc folder path.

If I do not add that, I get the following error message - WTArchitectView.h not found

And after adding it, I am getting folowing build error -

 

Undefined symbols for architecture i386:

  "_OBJC_CLASS_$_WTArchitectView", referenced from:

      objc-class-ref in WTWikitudePlugin.o

ld: symbol(s) not found for architecture i386

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

 

Hi,

Am I right that you want to build your project for the iOS simulator and that you're using Image Recognition? If so, I can tell you that the Wikitude SDK doesn't support the iOS Simulator because the Qualcomm SDK is not available for the iOS Simulator. There is a Wikitude SDK build for the simulator available that allows your App to compile for the Simulator target, but all rendering and camera capturing is disabled (The Wikitude SDK for the simulator is only available if you don't use Image Recognition). 

Best regards

Andreas

Thanks for replying. I am not using Image recognition and I want to build it for iphone which is currently  having ios 6.0.

Hi,

please check if your Library Search Paths really pointing to your libWikitudeSDK.a file and that your deployment target is really the iOS device and not the simulator. Please make also sure that your specified library search paths are really pointing to the iOS device / simulator version of your Wikitude SDK.

I have added library search path to point to this location - "$(SRCROOT)/WikitudeSDK/lib/Release-iphoneos". But still is not getting build

Any Suggestion?

Still getting the same error message.......

Hi,

can you please post the exact error message and tell me what device, iOS verision and Xcode version you're using.

Best regards

Andreas

 

Thanks for replying, atlast. I am currently using iPhone3GS and iPad 2. Both are having iOS6 and not working. I am getting Apple Mach-O linker error   "_OBJC_CLASS_$_WTArchitectView", referenced from: error during compilation   

 -

 

Ld /Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Products/Debug-iphoneos/WikiDemo.app/WikiDemo normal armv7

    cd /Users/hackintosh/Desktop/Apps/WikiDemo

    setenv IPHONEOS_DEPLOYMENT_TARGET 6.0

    setenv PATH "/Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Volumes/Xcode/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"

    /Volumes/Xcode/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch armv7 -isysroot /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS6.0.sdk -L/Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Products/Debug-iphoneos -LWikitudeSDK/SDK/lib/Release-iphoneos -L/Users/hackintosh/Desktop/Apps/WikiDemo/WikitudeSDK/Extensions/VuforiaExtension/lib -L/Users/hackintosh/Desktop/Apps/WikiDemo/WikitudeSDK/SDK/lib/Release-iphoneos -F/Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Products/Debug-iphoneos -filelist /Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Intermediates/WikiDemo.build/Debug-iphoneos/WikiDemo.build/Objects-normal/armv7/WikiDemo.LinkFileList -dead_strip -weak_framework CoreFoundation -weak_framework UIKit -weak_framework AVFoundation -weak_framework CoreMedia -weak-lSystem -force_load /Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Products/Debug-iphoneos/libCordova.a -Obj-C -lstdc++ -fobjc-link-runtime -miphoneos-version-min=6.0 -framework OpenGLES -framework Security -lsqlite3 -framework CoreMotion -framework CoreVideo -framework SystemConfiguration -lz /Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Products/Debug-iphoneos/libCordova.a -framework Foundation -weak_framework UIKit -framework CoreGraphics -framework AddressBook -framework AddressBookUI -framework AudioToolbox -weak_framework AVFoundation -framework CFNetwork -framework CoreLocation -framework MediaPlayer -framework QuartzCore -framework MobileCoreServices -weak_framework CoreMedia -o /Users/hackintosh/Library/Developer/Xcode/DerivedData/WikiDemo-dwctdyzbrkvsakgpatmmkrlepssn/Build/Products/Debug-iphoneos/WikiDemo.app/WikiDemo

 

 

Undefined symbols for architecture armv7:

  "_OBJC_CLASS_$_WTArchitectView", referenced from:

      objc-class-ref in WTWikitudePlugin.o

ld: symbol(s) not found for architecture armv7

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

 

One more thing I didn't understand this guide -

 

http://forum.wikitude.com/documentation?p_p_id=2_WAR_knowledgebaseportlet&p_p_lifecycle=0&p_p_state=normal&p_p_mode=view&p_p_col_id=column-2&p_p_col_count=1&_2_WAR_knowledgebaseportlet_mvcPath=%2Fdisplay%2Fview_article.jsp&_2_WAR_knowledgebaseportlet_resourcePrimKey=128189

 

I only understand the armv7 part, but I didn't understand in which file and what I have to do.

 

 

 

Hi,

can you please make sure that your Xcode project is setup properly. The WikitudeSDK folder should look like: 



 

and not like:



 

Best regards

Andreas

Hi,

Below are the screenshots(total = 4) from my xcode project settings, tell me if I am missing something.

Is there any problem with my configuration?

Hi,

Yes, there is a problem. You added the Wikitude SDK as folder reference and not as a group. Thats why the compiler/linker is not able to find the files. You can ether add the SDK as folder group or change the user header search path and library search path.

Best regards

Andreas

Tried both methods, but that didn't work . Do you have any working sample projects or what should I else do?
Login or Signup to post a comment