Start a new topic

PhoneGap App Issues

PhoneGap App Issues

1 person has this problem

Hey guys,

Grabbed your PhoneGap plugin, and have been trying it out. When I use your HelloWorld example (well I moved your HTML + JS into my own project because I couldn't build your samples as they were) I am getting numerous of these errors:


A2012-09-18 15:26:45.462 MyApp -: unrecognized selector sent to instance 0x5a0ef0


Now the AR world comes up fine on the iPad, and when I click the "Hello World" label, I get the following output in XCode.



2012-09-18 15:31:42.804 MyApp -: unrecognized selector sent to instance 0x5a0ef0

2012-09-18 15:31:42.805 MyApp *** WebKit discarded an uncaught exception in the webView:decidePolicyForNavigationAction:request:frame:decisionListener: delegate: <NSInvalidArgumentException> -: unrecognized selector sent to instance 0x5a0ef0


Any pointers? I know she's brand new so there may be a few bugs (or maybe it's something I am doing), but looks good so far! Good work!

The fix is to add the following lines to your WikitudePlugin.m file:



@implementation WTWikitudePlugin


@synthesize currentARchitectViewCallbackID;

@synthesize isUsingInjectedLocation;

@synthesize currentPlugInErrorCallback;


This solved it for me.


which version of Xcode are you using? You should have Xcode 4.4.1 (Xcode 4.5 will be out in a few days).


Best regards,


Hey guys,

So my above code fixed everything, and the project worked fine. I upgraded XCode to 4.5 (I was using 4.3).


My new project builds, and deploys fine for simulators and for devices.


However, the HelloWorld example of yours I used before (draws a simple label that says "Hello World") just stopped working. Everything loads, but you never see the Hello World label. No errors, no issues, just no display of the label GeoObject. 



Hey I have a similar issue here. The app builds just fine, but nothing is showed in the view. It is as if the html file is not loaded or displayed. The log shows "Architect world launched" so I know the callback at the end of loading is called.

Any ideas?

IOS 6, Xcode 4.5, Cordova 2.1


please make sure that the path where your world is in your app bundle(check if you used folder references or folder groups. The path is different then) is the same path that you hand over the Wikitude Plugin to load.

Best regards


The path is WikitudePlugin.loadARchitectWorld("assets/world/HelloWorld.html"); and if I check the file with the file inspector, the path relative to project is assets/world/HelloWorld.html . Just for the sake if it, I tested /assets/world/HelloWorld.html, but with no luck.

In build phases > copy bundle resources I have HelloWorld.html ... in assets/world

So as far as I can tell, everything looks good.

But in any case, shouldn't the system log a warning or something if it fails to load the file?


please have a look at this post. 

Best regards


Ok so thanks to your sample project I discovered the problem. I was using folder groups (yellow folder) and not folder references (blue). Now everything works fine! I still believe the sdk should say something in the console when it fails to load a file.

By the way, in your sample project, the asset folder is hardcoded to some relative path, it needs to be changed and cleaned up from the hidden .svn directories to be used as a reference.

Thanks for your help!
Login or Signup to post a comment