Start a new topic

minimum requirements not fulfilled

minimum requirements not fulfilled

Hi once again!

Unfortunately we don't have your device in the office.
To manually check what's missing on your device the following lines may help:

final LocationManager locManager = (LocationManager)context.getSystemService( Context.LOCATION_SERVICE );
final SensorManager sensorManager = (SensorManager)context.getSystemService( Context.SENSOR_SERVICE );

final boolean isCompassAvailable = sensorManager != null && sensorManager.getDefaultSensor( Sensor.TYPE_MAGNETIC_FIELD ) != null;

final boolean isGPSAvailable = locManager != null && locManager.getAllProviders() != null && locManager.getAllProviders().size() > 0;

final ActivityManager am = (ActivityManager)context.getSystemService( Context.ACTIVITY_SERVICE );
final ConfigurationInfo info = am.getDeviceConfigurationInfo();
final boolean isOpenGL20 = info.reqGlEsVersion >= 0x20000;

final boolean hasSdk8 = Build.VERSION.SDK_INT >= 8;

Log.i( "Device features available", "Compass: " + isCompassAvailable + "; GPS: " + isGPSAvailable +"; OPENGL: " + isOpenGL20 + "; Andoid-8: "+hasSdk8);

Hope that helps.

Cheers,
Andi
Hi Sebastian!

Thanks for pointing that out.
Your device has everything in place it needs. I just guess you forgot to set the required permissions in your Manifest so ARchitect can access Compass, Accelerometer and LocationService.

Please ensure to have following permissions set












if this does not solve the issue feel free to contact us via e-mail:
android (at) wikitude.com

(we'll then publish the solution after mail-conversation)
Hi, I am trying to use wikitude for Android on an HTC Desire C, it has Android version: 4.0.3 and OpenGL ES 2.0 2184622.

When I compile and run "SimpleARBrowser" in the device I see "minimum requirements not fulfilled". I wonder why as I fullfill the android and opengl version requirements.

Please help, kind regards,
Sebastian
Login or Signup to post a comment