Start a new topic

Capture Screen

 Iam facing problems when i want to capture the AR view with markers. Can any one helps, I have already read the documentation and still its not working ... following is the code


captureScreen: function captureScreenFn() {
if (World.initialized) {
document.location = "architectsdk://button?action=captureScreen";
}
},


Hello Abdul,


Please read carefully all the documentation. What I suggest you do is download our sample app and see how it is working there. You also need to put the code for the "Snapshot"-button. Once clicked the current screen is captured and user is prompted to share it.

 

<!-- header of UI holding feature buttons -->
        <div id ="header-status" data-role="header" data-position="fixed" data-theme="c">
            <a href="javascript: World.showRange();" data-icon="gear" data-inline="true" data-mini="true">Range</a>
            <a href="javascript: World.captureScreen()" data-icon="refresh" >Snapshot</a>
            <h1></h1>
        </div>

 

Thanks,

Eva

 Hi Eva,


I already downloaded the sample app but the snapshot feature is not working there as well. Is this have something to do with trail SDK ??


1 person likes this

That is a bit strange since we test our apps before launching them and no, trial key is irrelevant. So could you please give me the following information so that we can test internally?

- Which version of the SDK are you using? 

- Are you using the JS API?

- Are you using any of our Extensions (Titanium, Cordova, Xamarin, Unity)? If yes, which version are you using?

- What device does this happen with (os Version and model)?

SDK version="5.3.0"
Extension Used : Cordova
version: 6.4.0 Device: samsung s7 Edge Duos (Android OS, v6.0)

 Attched is the complete code

rar
(4.56 MB)
Any help ??

 

I posted the details you wanted and also attached the code, but that comment is not visible

 

Hi Abdul,


I just tested our Cordova sample on a Samsung S7 device and it is working as expected. I was able to see the button Snap and when pressed a screenshot was saved on the device. If you have modified the code then please check with our sample code. 


If it is still not working then please send us a video demonstrating all the steps you are taking from the beginning (like open the app, select 6.browsing pots etc.) and the error you are receiving.


Thanks,

Eva

It worked... but thats jquery mobile. Iam using framework7 in my project

 

Hi Abdul,

Can you please verify that it does not work with our example application as well? Which device are you using for your tests? Did you see the photo library access permission request?


Best regards,

Andreas


1 person likes this

Do not see any permission request popup. I am using version 7.2 on iPad.

Any advice?

Thanks

Hi Huy,

Are you using our example application or your own Cordova based application?


In our example app, you should see the permission request when entering the example. In case it's not shown, can you make sure that the permission is not already set in the App's Settings page? You might either grant access there or delete and install the example app again.


For your own application, please make sure that the `NSPhotoLibraryUsageDescription` (or `NSPhotoLibraryUsageDescription` on iOS 11 and later) .plist keys are set in your config.xml.


Best regards,

Andreas

Login or Signup to post a comment