Start a new topic

Android - DllNotFoundException: UnityEditorWindowsBridge in Expert Edition


I read a similar post:

where Peter replied that it only affects UWP.

I have the same problem in Android.
For example I use Unity Remote 5 to connect to my Android phone.
I set the Live Preview to Remote Camera.
I run any sample project (e.g.: Simple - Image Tracking), I get the following errors in the beginning and in the end:

- DllNotFoundException: UnityEditorWindowsBridge
- Error initializing C# functions! System.DllNotFoundException: UnityEditorWindowsBridge
And this error every frame:

- DrawGUITexture: texture is null

The phone screen shows the Wikitude UI but everything else is black.

Unity Version: 2020.3.33
Wikitude Version: Expert 9.13

(I use a valid license key which works fine in Pro Edition)

Thank you.

Developing operating system is Windows 10.

Hey Karastergiou,

unfortunately you're facing two separate issues here:

The first one is the same as in the post you've mentioned since that issue affects both the platforms UWP and Windows.

The second issue (DrawGUITexture) relates to the LivePreview.

Both errors have already been resolved and will be included in our next release v9.14. We're currently waiting for approval so we can publish the release, hence I'm unfortunately not able to tell you a specific date once it will be available. I hope you can wait for a bit until the new version is available.

In the meantime if you go into your build settings, change your platform to Android or iOS and build on your mobile device(s) the SDK should work just as normal. If you install the package "Android Logcat" from Unity's Package Manager you'll have a quite useful tool for debugging your code on Android devices.

I'm sorry for the inconvenience and hope that the new release with the bug fixes will be available soon.

With best regards,


Ok, thanks for the answer Peter.

There is also something strange happening in the Expert Edition (Unity 2020.3 - Android).
I create a GameObject and add the ObjectTracker component. It immediately shows two Target Collection Resource Events (OnFinishLoading and OnErrorLoading) and three Events (OnTargetsLoaded, OnErrorLoading and OnInitializationError).
If I select anything else in the Hierarchy, the ObjectTracker refreshes and now shows only the two Target Collection Resource Events. The other Events can be registered fine through code.
Is this an Inspector bug?

Hey Karastergiou,

this one is new to me. I'll take a look immediately.

With best regards,


I just created a new, empty project using Unity 2020.3.17, imported the Export Edition SDK (v.9.13) and created a new Object Tracker scene. I tried to reproduce mentioned issue but could always see both event groups ("Target Collection Resource Events" and "Events"). I also tried with all the samples making use of Object Tracking but had the same outcome.

Are there any errors in your consoles? If so can you share them with me?

Which concrete version of Unity are you using? v9.13 supports up to Unity 2020.3.17 but might behave strangely with newer versions. Our new soon-to-be-released SDK v9.14 will support Unity up to 2021.3.8. Maybe upgrading once it's available will get rid of this issue if your using a higher Unity version than 2020.3.17.

With best regards,


Hello Peter,

When I click on the Object Tracker game object, I get this console error message:

DllNotFoundException: UnityEditorWindowsBridge

WikitudeEditor.WindowsTargetCollectionBridge.WikitudeEditor.IMapCollectionBridge.LoadCollection (System.String wtoName) (at <26aaaf5f8a9e48ca9a35e076cefc7b80>:0)

WikitudeEditor.MapCollectionDatabase.LoadCollection (System.String relativePath) (at <26aaaf5f8a9e48ca9a35e076cefc7b80>:0)

WikitudeEditor.MapCollectionDatabase.GetCollection (System.String relativePath) (at <26aaaf5f8a9e48ca9a35e076cefc7b80>:0)

WikitudeEditor.ObjectTrackerInspector.GetTargetNameForAlignmentInitialization () (at <26aaaf5f8a9e48ca9a35e076cefc7b80>:0)

WikitudeEditor.ObjectTrackerInspector.OnEnable () (at <26aaaf5f8a9e48ca9a35e076cefc7b80>:0)

It's the same message as in the 1st post of this thread.
We use Unity 2020.3.33 version, so maybe that's the problem.

Kind regards.


Hello Karastergiou,

thank you for the error message. It seems that both issues are connected and are both related to the UWP/Windows issue mentioned in the original post. The next SDK release should get rid of that problem.

I know that it's already been months since you and others are waiting for the new 9.14 version to get rid of that issue and I'm really sorry that it takes so long. We're still waiting for approval to release it and I hope that you can still wait a bit longer until it's ready.

With best regards,


Login or Signup to post a comment