Start a new topic

Wikitude Camera has a FOV of "NaN" when Image Tracker is enabled


We are using Unity 2020.3.2 to build for UWP.

We are using the Wikitude SDK 9.6 Professional Edition.

We are facing yet another device-specific error :

One of our clients was using the "Latitude 7220 Rugged Extreme Tablet" (Windows 10 tablet) and everything was working fine.

Then they upgraded to the newest "Latitude 7230 Rugged Extreme Tablet".

Since then, AR is not working anymore. Wikitude is not able to detect any ImageTracker or InstantTracker. Actually, sometimes it works, but most of the times it doesn't...

No error is displayed by the Wikitude SDK.
However, I have found that after activating the ImageTracker gameobject, the WikitudeCamera's Camera component has a FieldOfView of "NaN" and also "NaN" values in its ProjectionMatrix.

I have printed a bunch of properties of the camera and it is the only thing that stands out. Please see the attached screenshot.

I have also attached some specs of each tablet model, not sure if it can help.

It is the first time we encounter this issue and we can't reproduce it on devices (UWP or Android), but I hope you may have an idea of why this is happening and if maybe this is something you have fixed in the latest versions of the SDK.

If you have any information about this issue that is preventing our client to use AR at all, please let us know.

Kinds regards,

Thales team

Hello Team Thales,

this sounds like a very specific issue indeed. We will have a look into it and see if we can reproduce the issue and find anything.

In the meantime have you tried upgrading your SDK version to the current 9.13 version? The SDK you're using is over two years old and maybe the issue might be resolved just by upgrading (just a guess, though).

With best regards,



We have have tried using the 9.13 SDK as you suggested (with a trial license), unfortunately this did not resolve the issue, the behavior and FieldOfView values did not change, AR is not usable at all.

Please, let us know if you are able to track down this issue.


Thales team

Login or Signup to post a comment