Start a new topic

Upload to Appstore Error ITMS-90338: Non-public API usage

The facts:

- Wikitude SDK 9.6.0

- macOS 12.4

- Xcode 13.4.1 (13F100)

- Unity 2020.3.34f1 - 2020.3.36f1


The problem:

The uploading process of my updated app to Apple's app store looks fine. But a few moments later a mail from App Store Connect arrives with the following text:


"We identified one or more issues with a recent delivery for your app, "NB" 0.4 (6). Please correct the following issues, then upload again.


ITMS-90338: Non-public API usage - The app references non-public symbols in Frameworks/WikitudeSDK.framework/WikitudeSDK: _TIFFDataWidth, _TIFFFieldDataType, _TIFFFieldName, _TIFFFieldPassCount, _TIFFFieldReadCount, _TIFFFieldTag, _TIFFFieldWithTag, _TIFFGetField, _TIFFGetFieldDefaulted, _TIFFMergeFieldInfo, _TIFFSetField, _TIFFSetTagExtender, __TIFFDataSize, __TIFFfree, __TIFFmalloc. If method names in your source code match the private Apple APIs listed above, altering your method names will help prevent this app from being flagged in future submissions. In addition, note that one or more of the above APIs may be located in a static library that was included with your app. If so, they must be removed. …"

I can't see the uploaded version in TestFlight. It's the first time I have this error.

How can I solve this issue? Is it a problem from Wikitude or Apple?

Kind regards

Björn



3 people have this problem

Hi Björn, I related the same issue in this topic a 13 days ago https://support.wikitude.com/support/discussions/topics/5000097155. I hope the answer this very soon, as this bug prevents me from uploading a new version of the app on iOS.

And three weeks earlier everything worked fine! Hopefully it is a bug somewhere. But maybe Apple's restrictions became harder again!?

 Hi Björn,


it seems like thats the case.


Wikitude support suggested us upgrading to 9.10 (maybe with a trial license/key, if you don't have access in the purchased one) and check if works.


We are doing this test right now. Will let you know if it works.


Regards,

Skd Version 9.10 works. App uploaded, processed , the error is gone. Waiting for a definitive solution to publish the app.

Thanks for the information.


This sounds like a solution for subscription license - we have onetime licenses. Hopefully the Wikitude team will come up with something good for us as well.


Happy coding!

Just tried Unity 2020.3.33f1 - same problem.


Same problem with Unity 2020.3.34f1 + Wikitude Expert 9.6

I just tested the new Wikitude SDK 9.10 and it works!

Where did you download Wikitude SDK 9.10 Expert Edition?

Current version is only Wikitude SDK 9.12
https://www.wikitude.com/download-wikitude-sdk-expert-edition-for-unity/

And older versions there is only SDK 9.9
https://support.wikitude.com/support/discussions/topics/5000091233

Anyway we need to negotiate with Wikitude as our license is/was perpetual (one-time) and not a subscription.

It should also work with 9.12, because the error is caused by an outdated library.


Three days ago there was the file "Wikitude_Expert_Edition_Unity_9-10-0_210824_6777.zip" on the website, I can't find it anymore, too.

Hi, 


The SDK version 9.10 has also been added on our table with all the previous versions here https://support.wikitude.com/support/discussions/topics/5000091233.


Wikitude Support Team

Login or Signup to post a comment