Start a new topic

Unity/iOS- The app references non-public symbols

Hi, I trying to publish a App and when the upload stages come up, this error shows up on the window:

The app references non-public symbols in Payload/[App].app/Frameworks/WikitudeSDK.framework/WikitudeSDK: _TIFFDataWidth, _TIFFFieldDataType, _TIFFFieldName, _TIFFFieldPassCount, _TIFFFieldReadCount, _TIFFFieldTag, _TIFFFieldWithTag, _TIFFGetField, _TIFFGetFieldDefaulted, _TIFFMergeFieldInfo, _TIFFSetField, _TIFFSetTagExtender, __TIFFDataSize, __TIFFfree, __TIFFmalloc With error code STATE_ERROR.VALIDATION_ERROR.11 for id 03e29261-3bdf-495a-af24-d8a330235534

I'm using Unity 2020.3.35f1, with Wikitude SDK 9.6.0, XCode 13.4.1
Trying to with Unity 2020.3.34f1, and/or XCode 13.3.1, same result.

Any help about this?

4 people have this problem

I have the same problem.

I'm using Unity 2021.3.4f1, and when I try to upload with XCode 13.4.1 or 13.3.1 I get the same error.

I managed to upload my app with XCode 13.2.1, but got the same error on App Store Connect.

2 people like this

Hi, I detailed this error

Steps to reproduce:

- Install Wikitude on Unity Project, build for iOS,

- In Xcode Build, go in "Product->Archive"

- After Archive, click in "Distribute App"

- In the next window select App Store Connect, click "Next"

- Select Upload, click "Next"

- Check "Include bitcode for iOS content", "Upload your app´s symbols", "Manager Version and Build Number" and click "Next"

- Select "Automatically manager signing" (in my case I'm using this way), click "Next"

- Click in "Upload" and wait a little

- The error appears

SDK Plataform and Version:

- Unity Expert Edition 9.6.0 SDK or Unity Standard Edition 9.4.0 SDK

Development Tools:

- Unity 2020.3.34f1 ~ Unity 2020.3.36f1

- Xcode 13.4.1 (13F100)

Screenshots in attachment

Login or Signup to post a comment