Start a new topic

Upgrade to SDK 9.10 throws errors

Hi,


after upgrading Wikitude JS SDK from 9.7 to 9.10 it stopped working.

On 9.7 everything works perfectly fine, but on newer versions we are getting these errors:

"Uncaught ReferenceError: AR is not defined", source: data:text/html, (1)"


We Followed migration notes and did everything noted there. I do not see any changes required in JS files?


We are using NuGet packages inside VisualStudio and Wikitude JS SDK is used with Xamarin app.




Hi,


The specific error you mention usually happens when something in the JS file is not implement in a correct way. May I ask you the steps you followed when upgrading the version?


Best regards,

Aitor.

Hi,


Thanks for your reply.

I understand that it is something in JS file but that is impossible to track, as everything is working on 9.7 SDK.

The steps we did are quite simple, update Nuget package in Visual Studio Nuget package manager, so nothing special there...

Are you testing with Android or iOS? In any case, did you check our migration notes: https://www.wikitude.com/external/doc/documentation/latest/xamarin/migration.html#migrate-to-910? It is possible that you need to apply some changes into the project before using 9.10.


Best regards,

Aitor.

Tried both Android and iOS app, it's the same, and there is definetly some part of JavaScript code that is not working on new SDK version...

We have done migration as stated in notes, but no change.

I see. Are you using one of our samples as a starting point to include AR in your application? If so, which one? Maybe by reviewing this specific sample, we can find where the issue is coming from. Otherwise, I would need to have access to the sample (html, js, css) you are using in order to reproduce your issue and find a solution for it.


Best regards,

Aitor.

Login or Signup to post a comment