Start a new topic

3D model's texture is not rendered on iPhone


I am experimenting with Wikitude SDK with company's idea.

but have some issue's hard to solve it.

Our app's 3D model is displayed as all black body on iPhone SE2. (please see attached "error-screenshot1-sp.jpg" screenshot file)

I haven't tested other iPhone but it works well on Android devices.

3d model files are too big to attache here.

You can find files here:

All model files here are not worked.

Any help for this will be appreciated.

> Which version of the SDK are you using and are you working with the JS API or the Native API?

We're using JS API.

SDK Version: 9.10.0

Build Date: Mon Aug 23 23:03:44 2021

Build Number: 6776-520

> Are you using any of our Extensions or SDK for Smartglasses (Cordova, Xamarin, Unity)? If yes, which extension are you using?

No extensions

> If you work with Unity, what Unity version are you using?

No Unity

> If you work with Cordova, what Cordova version are you using?

No Cordova

> If you work with Xamarin, what Xamarin version are you using?

No Xamarin

> What device does this happen with (model details and OS version)?

iPhone SE2 (MXD02KH/A) iOS 15.4.1

> Is this happening with the sample app or in your own app? If it happens with your own app, does the sample app work on your device?

Our app. The sample app works on our device.

> Send steps to reproduce the issue and include the target images.

Attached FBX and wt3 model not worked on iPhone SE2 but worked well same model on Android devices.

> In case you upgraded the SDK version and the issue happens since the update, did you make sure to check the migration guide to see if something changed?

Not the case

> Did you make sure to follow the documentation and the setup guide?

The javascript files are almost as same as samples

1 Comment

it's resolved by down-sizing texture file

Login or Signup to post a comment