Start a new topic

fatal error: 'WikitudeSDK/WikitudeSDK.h' file not found


I have created an app with Flutter 9.10 and once I build the iOS app I get below error.


 In file included from /Users/michael_papado/Documents/devs/nafpaktos/plugin_9.10/ios/Classes/ArchitectWidget.m:9:
    /Users/michael_papado/Documents/devs/nafpaktos/plugin_9.10/ios/Classes/ArchitectWidget.h:12:9: fatal error: 'WikitudeSDK/WikitudeSDK.h' file not found
    #import <WikitudeSDK/WikitudeSDK.h>
1 error generated.
    warning: /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3CM2ENP77I0GB/Accelerate-KJIHTHQ2QTZV.pcm: No such file or directory
    note: while processing /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3CM2ENP77I0GB/Accelerate-KJIHTHQ2QTZV.pcm
    note: The clang module cache may have expired since this object file was built. Rebuilding the object file will rebuild the module cache.
    warning: /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3CM2ENP77I0GB/CoreMotion-RZ4DJFEI29KM.pcm: No such file or directory
    note: while processing /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3CM2ENP77I0GB/CoreMotion-RZ4DJFEI29KM.pcm
    warning: /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3GSO36ODTI67V/Accelerate-KJIHTHQ2QTZV.pcm: No such file or directory
    note: while processing /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3GSO36ODTI67V/Accelerate-KJIHTHQ2QTZV.pcm
    note: The clang module cache may have expired since this object file was built. Rebuilding the object file will rebuild the module cache.
    warning: /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3GSO36ODTI67V/CoreMotion-RZ4DJFEI29KM.pcm: No such file or directory
    note: while processing /Users/michael_papado/Library/Developer/Xcode/DerivedData/ModuleCache.noindex/3GSO36ODTI67V/CoreMotion-RZ4DJFEI29KM.pcm
    note: Using new build system
    note: Planning
    note: Build preparation complete
    note: Building targets in dependency order

    Can you please assist on solving this.

Hello, I would highly appreciate if I can have a reply on this


to assist further on the error that I get, the application is made with Flutter dart 2.2 and 9.10 plugin.

On Android the app is already published.

I am embedding the WikitudeSDK.Framework from plugin/ios/Frameworks/WikitudeSDK.xcframework/ios-arm64.

Thank you 


The flutter build ios command generates a CocoaPods .xcworkspace that includes our framework, based on the path defined in the podspec file within our plugin.

You are probably building the app from the .xcodeproj, which doesn't include the CocoaPods files and references, so it isn't able to find our framework. Please make sure to open the .xcworkspace and build the app there. This should be located in the same directory as the .xcodeproj, after running Flutter's build command.

Here's our Flutter sample app project for more details:

- Damian

Hi Damian,

no, I have opened xcworksace and I can test the application on my mobile, but when I try to create the archive from xcode for publishing or with flutter build ios I get the error that I mention


So you have a .xcworkspace that is able to build and run the app on your iOS device, right? The flutter build ios command is the one that generates the .xcworkspace. Since you claim this command is failing, how did you get the workspace that you are using right now?

Did you already try to run flutter clean in the root of your project, and then flutter build ios again?

Can you post the full output of the flutter build ios command?

Can you build our sample app successfully? Does the pubspec.yaml in the root of your project declare the augmented_reality_plugin_wikitude the same way that our sample project does? Is the path here actually pointing to the plugin directory in your system? Did you move or modify the plugin in any way?

- Damian

Hi Damian,

attached is the full log of the flutter build ios command.

In order to run the app on my mobile I have opened xcworkspace with xcode, and run the project directly to my mobile instead of the simulator from xcode.

(52.8 KB)


The error you reported was in ArchitectWidget.h, the one in your latest log is in WikitudePlugin.h. Did you change anything in the project since Friday?

Some cached data may be causing trouble, I would suggest to: 

1. Delete the contents of /Users/michael_papado/Library/Developer/Xcode/DerivedData/

2. Navigate to the root of your Flutter project and run flutter clean

3. Run flutter build ios again

Please answer the rest of the questions in my previous post, and I may be able to help you further.

- Damian

Hi Damian,

I have delete all files from the DerivedData, run flutter clear and then build ios and got the log as per attached file.

I do not recall how the xcworkspace was created, but I suppose it was created with the flutter initiallization.

The sample project I haven't run it, but I have build another project with the wikitude plugin 9.8.

The pubspec.yaml contains the path of the augmented_reality_plugin_wikitude as "path: ./plugin_9.10/" and the plugin rests on the folder plugin_9.10 on the root of the project.

Just to write again that the Android app is build and published already on the Google Play Store, so the pubspec is correct.

Also I have tried after cleaning the project to add the Wikitude Framework on the Frameworks, Libraries and Embedded Content on Xcode and once I tried to create Product > Archive I got below error.


Multiple commands produce '/Users/michael_papado/Library/Developer/Xcode/DerivedData/Runner-dukcezbfvbbbapeyjqsukqtbsovy/Build/Intermediates.noindex/ArchiveIntermediates/Runner/InstallationBuildProductsLocation/Applications/'

Target 'Runner' (project 'Runner') has copy command from '/Users/michael_papado/Documents/devs/nafpaktos/ios/WikitudeSDK.xcframework/ios-arm64/WikitudeSDK.framework' to '/Users/michael_papado/Library/Developer/Xcode/DerivedData/Runner-dukcezbfvbbbapeyjqsukqtbsovy/Build/Intermediates.noindex/ArchiveIntermediates/Runner/InstallationBuildProductsLocation/Applications/'

That command depends on command in Target 'Runner' (project 'Runner'): script phase “[CP] Embed Pods Frameworks”


(27.2 KB)


The only way I could reproduce something similar to your error is when the s.vendored_frameworks field in plugin/augmented_reality_plugin_wikitude/ios/augmented_reality_plugin_wikitude.podspec points to the wrong path.

Please follow these steps:

1. Remove the current plugin from your project's plugin directory, download the latest version of our Flutter plugin and move it to the plugin directory in your project again. Make sure that the directory hierarchy in your project matches the one from our sample app.

2. In your project's ios directory, remove Podfile and Podfile.lock. In the same directory, run pod deintegrate and then pod clean.

3. Back in the root of your project, run flutter clean and flutter build ios.

You don't need to embed the framework manually, the CocoaPods setup handles the framework.

If your project still fails to build, please compare your project's General and Build Settings to the ones in our sample app project.

If you send us a project where these issues can be reproduced, we can take a deeper look into it.

- Damian

Hi Damian,

So this actually worked.

Don't know what it could have been wrong with the podfile, but now it actually worked.

I would suggest to renew the guide on the page because the one that it's currently available it makes things more complicated.

Thank you.

Login or Signup to post a comment