Start a new topic

Wikitude Android Camera Failure - Unity Location-Based App

I am working on a team to develop an app similar to Pokemon Go which uses Wikitude's AR Camera kit and Mapbox's geolocation tools to interact with AR objects based on geolocation. Wikitude has worked fine for iOS, but we have recurring issues with Android integration. When our client opens the app on his Android device and moves to the scene which uses the Wikitude camera, the AR lines appear on a completely black screen (see image below). Other members of our team have been successful in using the same builds on other Android devices, which leads me to believe it is a setting or compatibility issue with this specific Android device. Does anyone have experience with this error?


SDK version: Wikitude for Unity9.10 with Native API

Not using any extensions

Unity version: 2020.3.17

Not using Cordova

Not using Xamarin

Device: Galaxy S10+ with Android version 12, One UI version 4.0

Happening in own app, but sample app (and previous iterations of own app) worked on device

Steps to reproduce: open app, Approve Access to Wikitude While Using This App, move to scene with Wikitude camera in it

SDK version has not been upgraded during development

Documentation and setup guide was followed

1 person has this problem

Thanks!  We will try the AR Core Optional setting.  Maybe that's what the previous developer did.  You all are very helpful!!

I am not sure what the desired settings are. If the device doesn't have AR Core installed but in Unity the settings are set to "AR Core required", changing that to "AR Core optional", like described here, should do the trick...

That would be my first guess at the moment. A developer could get to the bottom of the issue more efficiently with the Unity project at hand.

Kind regards,

Also, could you please post the Unity settings to properly activate AR Core here?  In our prior build, our developer realized he missed a step.  After changing, it worked on my phone.  Unfortunately, during the hand-off process, this build was lost and the developer is not accessible.

I'm not sure. How can I tell which games use AR Core? I have a lot of AR games on this phone.

I am not quite sure... It seems that ARCore is not starting for some reason, but is installed on the device? Are other ARCore enabled applications working as expected?

Kind regards,

Here is the logcat!  


Hi Micky,

seemingly my former message got cut off sorry.

I also posted a link to a tutorial before:

Kind regards,


@gokhan - How do we capture the logcat output?

Hi Micky,
I also suspect that

@gokhan - How do we capture the logcat output (I suspect our developer already knows)?

Hi all,
Could you share the logcat output of the application?

Kind regards,

Bump - any ideas on where to start in trouble-shooting device-specific errors?  

Oh and the black screen above freezes after 1 second and then the app crashes.
Wikitude team, Is there a debug logging mode or tips on how to approach this issue?
Login or Signup to post a comment