Start a new topic

I can't run the Flutter SDK sample project

Hi, I downloaded the Flutter SDK sample project and I can't run it. Below is the error that it generates and then the detail of what is installed generated by flutter doctor:


Doctor summary (to see all details, run flutter doctor -v):

[✓] Flutter (Channel stable, 2.8.1, on macOS 11.6.2 20G314 darwin-x64, locale es-419)

[✓] Android toolchain - develop for Android devices (Android SDK version 32.0.0)

[✓] Xcode - develop for iOS and macOS (Xcode 13.2.1)

[✓] Chrome - develop for the web

[✓] Android Studio (version 2020.3)

[✓] VS Code (version 1.63.2)

[✓] Connected device (2 available)


• No issues found!


The OS is Big Sur


moodtechnology@MacBook-Pro-de-MooD wikitude-flutter-plugin-examples-master % flutter run

The plugin `augmented_reality_plugin_wikitude` uses a deprecated version of the Android embedding.

To avoid unexpected runtime failures, or future build failures, try to see if this plugin supports the

Android V2 embedding. Otherwise, consider removing it since a future release of Flutter will remove these

deprecated APIs.

If you are plugin author, take a look at the docs for migrating the plugin to the V2 embedding:

https://flutter.dev/go/android-plugin-migration.

Using hardware rendering with device sdk gphone x86. If you notice graphics artifacts, consider enabling

software rendering with "--enable-software-rendering".

Launching lib/main.dart on sdk gphone x86 in debug mode...

Note: Some input files use or override a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

Note: /Users/moodtechnology/Downloads/wikitude-flutter-plugin-examples-master/plugin/augmented_reality_plugin_wikitude/android/src/main/java/com/wikitude/wikitude_plugin/WikitudePlugin.java uses unchecked or unsafe operations.

Note: Recompile with -Xlint:unchecked for details.

Running Gradle task 'assembleDebug'...                            101.6s

✓  Built build/app/outputs/flutter-apk/app-debug.apk.

Installing build/app/outputs/flutter-apk/app.apk...                 5.0s

E/FlutterLoader(11717): Flutter initialization failed.

E/FlutterLoader(11717): java.util.concurrent.ExecutionException: java.lang.UnsatisfiedLinkError: dlopen failed: library "libflutter.so" not found

E/FlutterLoader(11717):         at java.util.concurrent.FutureTask.report(FutureTask.java:123)

E/FlutterLoader(11717):         at java.util.concurrent.FutureTask.get(FutureTask.java:193)

E/FlutterLoader(11717):         at io.flutter.embedding.engine.loader.FlutterLoader.ensureInitializationComplete(FlutterLoader.java:223)

E/FlutterLoader(11717):         at io.flutter.embedding.engine.FlutterEngine.<init>(FlutterEngine.java:326)

E/FlutterLoader(11717):         at io.flutter.embedding.engine.FlutterEngine.<init>(FlutterEngine.java:206)

E/FlutterLoader(11717):         at io.flutter.embedding.android.FlutterActivityAndFragmentDelegate.setupFlutterEngine(FlutterActivityAndFragmentDelegate.java:256)

E/FlutterLoader(11717):         at io.flutter.embedding.android.FlutterActivityAndFragmentDelegate.onAttach(FlutterActivityAndFragmentDelegate.java:166)

E/FlutterLoader(11717):         at io.flutter.embedding.android.FlutterActivity.onCreate(FlutterActivity.java:459)

E/FlutterLoader(11717):         at android.app.Activity.performCreate(Activity.java:8000)

E/FlutterLoader(11717):         at android.app.Activity.performCreate(Activity.java:7984)

E/FlutterLoader(11717):         at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1309)

E/FlutterLoader(11717):         at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3422)

E/FlutterLoader(11717):         at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3601)

E/FlutterLoader(11717):         at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:85)

E/FlutterLoader(11717):         at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:135)

E/FlutterLoader(11717):         at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:95)

E/FlutterLoader(11717):         at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2066)

E/FlutterLoader(11717):         at android.os.Handler.dispatchMessage(Handler.java:106)

E/FlutterLoader(11717):         at android.os.Looper.loop(Looper.java:223)

E/FlutterLoader(11717):         at android.app.ActivityThread.main(ActivityThread.java:7656)

E/FlutterLoader(11717):         at java.lang.reflect.Method.invoke(Native Method)

E/FlutterLoader(11717):         at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:592)

E/FlutterLoader(11717):         at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:947)

E/FlutterLoader(11717): Caused by: java.lang.UnsatisfiedLinkError: dlopen failed: library "libflutter.so" not found

E/FlutterLoader(11717):         at java.lang.Runtime.loadLibrary0(Runtime.java:1087)

E/FlutterLoader(11717):         at java.lang.Runtime.loadLibrary0(Runtime.java:1008)

E/FlutterLoader(11717):         at java.lang.System.loadLibrary(System.java:1664)

E/FlutterLoader(11717):         at io.flutter.embedding.engine.FlutterJNI.loadLibrary(FlutterJNI.java:123)

E/FlutterLoader(11717):         at io.flutter.embedding.engine.loader.FlutterLoader$1.call(FlutterLoader.java:174)

E/FlutterLoader(11717):         at io.flutter.embedding.engine.loader.FlutterLoader$1.call(FlutterLoader.java:166)

E/FlutterLoader(11717):         at java.util.concurrent.FutureTask.run(FutureTask.java:266)

E/FlutterLoader(11717):         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)

E/FlutterLoader(11717):         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)

E/FlutterLoader(11717):         at java.lang.Thread.run(Thread.java:923)

E/AndroidRuntime(11717): FATAL EXCEPTION: main

E/AndroidRuntime(11717): Process: com.wikitude.fluttersamples, PID: 11717

E/AndroidRuntime(11717): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.wikitude.fluttersamples/com.wikitude.fluttersamples.MainActivity}: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.UnsatisfiedLinkError: dlopen failed: library "libflutter.so" not found

E/AndroidRuntime(11717):        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3449)

E/AndroidRuntime(11717):        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3601)

E/AndroidRuntime(11717):        at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:85)

E/AndroidRuntime(11717):        at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:135)

E/AndroidRuntime(11717):        at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:95)

E/AndroidRuntime(11717):        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2066)

E/AndroidRuntime(11717):        at android.os.Handler.dispatchMessage(Handler.java:106)

E/AndroidRuntime(11717):        at android.os.Looper.loop(Looper.java:223)

E/AndroidRuntime(11717):        at android.app.ActivityThread.main(ActivityThread.java:7656)

E/AndroidRuntime(11717):        at java.lang.reflect.Method.invoke(Native Method)

E/AndroidRuntime(11717):        at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:592)

E/AndroidRuntime(11717):        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:947)

E/AndroidRuntime(11717): Caused by: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.UnsatisfiedLinkError: dlopen failed: library "libflutter.so" not found

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.loader.FlutterLoader.ensureInitializationComplete(FlutterLoader.java:315)

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.FlutterEngine.<init>(FlutterEngine.java:326)

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.FlutterEngine.<init>(FlutterEngine.java:206)

E/AndroidRuntime(11717):        at io.flutter.embedding.android.FlutterActivityAndFragmentDelegate.setupFlutterEngine(FlutterActivityAndFragmentDelegate.java:256)

E/AndroidRuntime(11717):        at io.flutter.embedding.android.FlutterActivityAndFragmentDelegate.onAttach(FlutterActivityAndFragmentDelegate.java:166)

E/AndroidRuntime(11717):        at io.flutter.embedding.android.FlutterActivity.onCreate(FlutterActivity.java:459)

E/AndroidRuntime(11717):        at android.app.Activity.performCreate(Activity.java:8000)

E/AndroidRuntime(11717):        at android.app.Activity.performCreate(Activity.java:7984)

E/AndroidRuntime(11717):        at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1309)

E/AndroidRuntime(11717):        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3422)

E/AndroidRuntime(11717):        ... 11 more

E/AndroidRuntime(11717): Caused by: java.util.concurrent.ExecutionException: java.lang.UnsatisfiedLinkError: dlopen failed: library "libflutter.so" not found

E/AndroidRuntime(11717):        at java.util.concurrent.FutureTask.report(FutureTask.java:123)

E/AndroidRuntime(11717):        at java.util.concurrent.FutureTask.get(FutureTask.java:193)

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.loader.FlutterLoader.ensureInitializationComplete(FlutterLoader.java:223)

E/AndroidRuntime(11717):        ... 20 more

E/AndroidRuntime(11717): Caused by: java.lang.UnsatisfiedLinkError: dlopen failed: library "libflutter.so" not found

E/AndroidRuntime(11717):        at java.lang.Runtime.loadLibrary0(Runtime.java:1087)

E/AndroidRuntime(11717):        at java.lang.Runtime.loadLibrary0(Runtime.java:1008)

E/AndroidRuntime(11717):        at java.lang.System.loadLibrary(System.java:1664)

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.FlutterJNI.loadLibrary(FlutterJNI.java:123)

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.loader.FlutterLoader$1.call(FlutterLoader.java:174)

E/AndroidRuntime(11717):        at io.flutter.embedding.engine.loader.FlutterLoader$1.call(FlutterLoader.java:166)

E/AndroidRuntime(11717):        at java.util.concurrent.FutureTask.run(FutureTask.java:266)

E/AndroidRuntime(11717):        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)

E/AndroidRuntime(11717):        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)

E/AndroidRuntime(11717):        at java.lang.Thread.run(Thread.java:923)

Login or Signup to post a comment