Start a new topic

3D model positioning

We have created scene (point cloud) and you can see its parameters in the photo attached. We have added model and positioned it to fit the scene (photo attached). When we use the parameters in the code, model does not show as it should (photo attached). But later we have changed rotation around X axis value and it worked well (photo attached). We have also added photo we have used for testing. Keep in mind that we experienced same problems on site. 

About the SDK version from our Android Studio project:


Here is the code snippet that we used to load the model:

        var modelScale = 0.0035;

        var model = new AR.Model("assets/model.wt3", {
            scale: {
                x: modelScale,
                y: modelScale,
                z: modelScale
            translate: {
                x: -1.257,
                y: 0.133,
                z: 0.532
            rotate: {
                x: 70,
                y: 270,
                z: 270
            onError: World.onError

As you can see, parameter rotate is not working as expected. We tweaked the X-axis to 70 and that worked fine but in your online editor it clearly stated 110. We had this problem with almost all of our models, manually tweaked them in order to get it right. Why is that? We would gladly share our source code with you on GitHub. 

Best regards, 


(1.02 MB)
1 Comment


We are looking into the issue and we are able to reproduce it. Please, for now trust only the values you set in the application side until we find the root cause of it. Sorry for the inconvenience.



Login or Signup to post a comment