Start a new topic

Wikitude's maven repo returning HTTP 403 error status code


we are using Wikitude SDK 9.6.0 to develop a React Native app and we've started to get problems developing and testing for Android, not having an issue during the last three months. An HTTP 403 error code is being returned by Wikitude's maven Repository CDN, starting this morning (GMT+2 timezone), when compiling our mobile app for Android.

We've been using the Wikitude's maven repository, since a couple of months till today, with no issues at all. This is the very first time that this issue appears on our project, and first happening to us with Wikitude at all.

Our project points the problem is originated when trying to fetch maven repo listing at:, with logs showing the issue, as follow:

      > Failed to list versions for com.facebook.react:react-native.

         > Unable to load Maven meta-data from

            > Could not get resource ''.

               > Could not GET ''. Received status code 403 from server: Forbidden

Testing URL manually, as well as TLD of the Repository domain (, always ends on a 403 error status code returned by server.

We've tried from different locations to check if there may have been any throttling mechanisms but no luck. Same 403 error from anywhere we've been able to check from Spain.

We already have our Wikitude integration done as of a month ago, and we're now working on other aspects of the app, so no changes around Wikitude into our development workflow.

Anyone experiencing this issue? Any help? It's frightening to approach our deadlines with such weird behaviour change on Wokitude's maven repo.

Hi Eventos,

Thank you for reporting this issue. I wanted to inform you that it has been assigned to a tech member and he will start investigating it and will provide you feedback.

Wikitude Support Team


I have tested our sdk 9.6.0 version that we have uploaded in our maven repository and everything seems to be working fine in our sample app ( It is possible that some of your latest changes in the application may have caused some short of conflict with our sdk such as removing the JCenter() repository from the gradle file (as required in

Could you please check if some of the latest changes in your application is causing this issue so we can create a proper internal ticket to add support for it in the near future? Otherwise I am not able to reproduce it.

Sorry for the inconvenience and thank you for letting us know about this one.



Hi. So far we're still receiving 403 response when compiling project. We have cloned some repo revisions from the past weeks and the problem persists. At the end we managed to provide a local copy of the wikitude.aar to keep coding. We tried demo app, and same 403 error when compiling process tries getting wikitude's remote maven repo. Is there any chance we are being IP banned or throttled? Thanks

Hi again,

I have downloaded our sample app from the website and used the maven url to use our 9.6.0 version and everything seems to be working fine on my end. I would suggest you to use the aar file you already have until we find out what's going on with the url in you specific case (so far you are the only one with this issue that I'm aware of).

Best Regards,


Login or Signup to post a comment