Start a new topic
Solved

Sometime iOS gets a black screen instead of the camera view

We have an app using Wikitude 9.5, Javascript SDK.


A few users successfully opened the AR View, closed it, opened it and so on a few times, to eventually run into a black screen on the AR View.


Any idea what is happening when the black screen is visible, what is failing / happening?


I do notice that even on the successful attempts, there is a black screen flickering once when starting the camera view. That means, the camera view is visible for a second, then a black layers covers it all up for a split of a second and disappears, then the rest continues as normal.


Thank you for the advice Nicola. Have a wonderful day.

Hi George,


as you can't reproduce this issue and it's also something that we haven't heard from other partners, it's hard to narrow down the exact issue. 


Potential reasons could be that you're not stopping and removing the ArchitectView properly or maybe your specific setup allows for the user to close and open this view very fast without the proper checks, and they may be attempting to start a new ArchitectView while the previous one still hasn’t stopped completely yet. So it could be that the start method is not being called in the ArchitectView at the point where the black screen gets stuck.


Once this is reproducible, please check weather all the start and stop calls are happening in the right order.


Thx and greetings

Nicola


The black screen appears and disappears quickly for for our app and the sample app.


Getting the black screen stuck I have not been able to get either on our app or the sample app. However some users reported getting this.

Hi,


does this also happen with the unchanged 9.5 SDK sample app? If not, could you check for differences in the loading / startup process?


Thx and greetings

Nicola

Login or Signup to post a comment