Start a new topic
Solved

Wikitude PE 9.5 Object Tracking Preview doesn't work

I want to enable model preview, but I can't. Obviously, without this feature, development will not be effective. I tried to enable preview in expert edition as well. Nothing comes out. Tried loading my models and using demo scenes all the same. Help me please.

https://drive.google.com/file/d/1bhvP79Ishm_PbtOg0P-L24dsTjfw9Bhl/view?usp=sharing - demonstration


Hi,

I just saw that you were using SDK 9.5. Could you try updating to the 9.6 version? We fixed an issue with the point cloud in this release (https://www.wikitude.com/external/doc/documentation/latest/unity/changelog.html#fixed)


Kind regards,
Gökhan


1 person likes this

Hi,

since the point cloud is just a frozen particle system, you might have disabled some settings in the scene view... Could you try to reset your Editor layout (with the dropdown in the top right corner of the Unity Editor)?


(Seems like this same issue: https://www.youtube.com/watch?v=lQ4kntPYbTo)


Kind regards,
Gökhan


1 person likes this

And resetting the Editor layout is also not working?


1 person likes this

Hello,
the Firetruck's size is smaller than 1 meter, so you have to zoom in real close. There is no way at the moment to automatically zoom in. You can also deactivate the Gizmos in the scene by clicking on the Gizmo dropdown in the Scene View's toolbar.

Kind regards,
Gökhan


1 person likes this

Okey, thank you

https://drive.google.com/file/d/1QEbWJeisyMcARoMRsr3HX9iyQUweCDAe/view?usp=sharing - PE 9.6 object tracking demonstration


https://drive.google.com/file/d/1W3B8bY5jPTcn674-BDyJlB-o4GkzFa0d/view?usp=sharing - EE 9.6 object tracking demonstration

I didn't notice the difference.

"Camera frame rendering in Unity Editor Live Preview on Windows with High DPI settings". Maybe you need to enable this "High DPI settings"? I do not understand what the problem is.

https://drive.google.com/file/d/1aDQDsxJYaPe8-KtVzduIFzt1fptVTZyD/view?usp=sharing - demonstration


I've tried using the particle system. It works, but the preview doesn't.

I have tried using version Wikitude 9.3.1 along with Unity 2018.4.5f1. Everything works. However, newer versions do not.

I found a solution to the problem. There was simply no tick in the particle system. Thank you. You were helpful!

image

Glad that this is resolved. We'll consider throwing a warning in the console if this setting is disabled.


Kind regards,
Gökhan

Take a look. I turned off Gizmo. I tried to increase the size of the Firetruck. Zoomed in as close as possible. Nothing comes out. 

I really need this function, moreover, I remember that I used it and everything worked. I don't understand what has changed. It is very sad from this.

https://drive.google.com/file/d/1XE8nIl6TU-_e7fPZJV-aRgcT9ovApGQ8/view?usp=sharing - Demonstration

Hi,

For custom target's the calculated size can be different from the real world scale. You could also try to increase the max point cloud size to 100 and see if it shows up then.

I proposed an automatic focus upon clicking preview. This might help in such cases for the future.

If increasing the point cloud size doesn't help, could you please send the target collection to support@wikitude.com and mention this thread? I could have a look at it then.


Kind regards,
Gökhan

Login or Signup to post a comment