Start a new topic

Unity and error 1006: "Unable to change the recognition type for the target"

I am using Unity 2019.4.11f1 with the latest Wikitude Unity SDK package (version 9.4.0, I think) and I am trying a few experiments to use my own models on the test scenes. I have been able to track a JoyCon and make an alignment model for it by means of replacing the provided firetruck mesh.

While the app can be compiled and runs on Android and besides a pending issues regarding scales and rotations I still have to fix, there is a log that pops up every time I run the object tracking alignment scene:

Error initializing tracker!

        Error Code: 1006

        Error Domain: com.wikitude.computer_vision_interface

        Error Message: Unable to change the recognition type for the target firetruck_realScale

I have trying searching everywhere for an occurence of "firetruck_realScale" and it seems that apprears as blank in a prefab file and that is overriden in an instance of such prefab, but it is nowhere to be found through the Unity inspector. I cannot find these references to the scale of the firetruck, and trying to search for this exact message text yields no results anywhere. Otherwise, the app can be run and the other demos work well.

Is there anything I can do to fix this issue? Thank you very much in advance.

Hi Juan,

Seems like the Object Tracker component didn't update the target name for alignment initialization.
Could you select the Object Tracker and toggle the "Use alignment initialization" toggle off and on again?

Kind regards,

Superb, that solved the issue, thank you so much!

Login or Signup to post a comment